Jump to content


My engine sounds mod - 0.8.6

Work-around script no longer

  • This topic is locked This topic is locked
342 replies to this topic

NoblePlatoon #1 Posted Mar 20 2012 - 04:14

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011
OK...I have jumped back into the fray, and made my own engine sounds mod. The sounds engine sounds I chose are from a Leopard, Ford GAA V8 (M4A3 Sherman), Maybach HL 230 (Tiger I), Maybach HL 42 and Maybach 160.

Only look in the spoiler if you want to see the progress of this mod. Many of the links are broken, as they are older versions.
Spoiler                     

v4a2 Allison and v4b2 Continental Radial
Modified tread sounds for further authenticity
Re-worked near-distance parameters so tanks close to you won't be so overwhelmingly loud
Re-worked some rev parameters to give a smoother acceleration sound
Other esoteric parameter adjustments
I have included a quiet pre-start version, in addition to the idle at pre-start

v4a2 Allison idle at pre-start
v4a2 Allison quiet pre-start
v4b2 Continental Radial idle at pre-start
v4b2 Continental Radial quiet pre-start



No longer need the work-around as of 0.8.6
If you don't know what I mean, then just ignore this comment.

Installation instructions
Spoiler                     

Edited by NoblePlatoon, Jun 28 2013 - 19:33.


Terminus_Hostilia #2 Posted Mar 20 2012 - 05:18

    Staff sergeant

  • Players
  • 18946 battles
  • 273
  • [2K1LL] 2K1LL
  • Member since:
    02-27-2011
Is this one that requires the entire audio folder to be pasted in the res_mods folder?

NoblePlatoon #3 Posted Mar 20 2012 - 05:31

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011

View PostTerminus_Hostilia, on Mar 20 2012 - 05:18, said:

Is this one that requires the entire audio folder to be pasted in the res_mods folder?
It is not required on my game client, but I know others require such when they install sound mods.

Terminus_Hostilia #4 Posted Mar 20 2012 - 05:44

    Staff sergeant

  • Players
  • 18946 battles
  • 273
  • [2K1LL] 2K1LL
  • Member since:
    02-27-2011
Ok..it required it on mine. Tried it w/o and had no sound.

One more question...Is this to replace sounds for all tanks?
I can't really tell the difference in the game.

FinnFann #5 Posted Mar 20 2012 - 05:53

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011
  Worked. Sounds could use a little higher quality, although they're all working (most sound really "crunchy" at the top of notes). Had to rename the fev file to "vehicles" and keep the fsb "vehicle" in order for it to work. Had an odd "hiss" noise when the VK4502 Aufs A was at full speed (although this may have been caused by an american engine nearby. I'm not entirely sure after playing a different replay file), though, and it tended to go from low speed to high so fast that the sound change between slow, medium, and fast was just awkward sounding at times.

Could also use softening the idle sounds a little due to the fact that all the idle sounds from all engines at once at the beginning of a match are quite loud. All-in-all I'm just glad to see more engine sound mods, and I'm more than willing to help develop this one, given I'm unsure how long the Wot War Atmosphere engine sounds will be missing the light tanks (By god, though, his jagdtiger engine sounds are astounding). EDIT: Yes I had enough time to figure all this out even though you just posted this :B I keep a replay file handy of each tank type, and I use them to test mods rather than a live battle. 




Summed up: It works, but could use some work. I'm just happy to see a second engine mod, though. 



anarchyxf36 #6 Posted Mar 20 2012 - 06:13

    First lieutenant

  • Players
  • 21307 battles
  • 938
  • [86TH] 86TH
  • Member since:
    04-22-2011
-1 cause the sounds didn't work even after renaming the files. im sticking with WoT War Atmosphere's T90 engine sounds for now. I will +1 if you get this mod working good though  :Smile_great:

FinnFann #7 Posted Mar 20 2012 - 06:23

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View Postanarchyxf36, on Mar 20 2012 - 06:13, said:

-1 cause the sounds didn't work even after renaming the files. im sticking with WoT War Atmosphere's T90 engine sounds for now. I will +1 if you get this mod working good though  :Smile_great:

I'll agree with you that I'm EAGERLY waiting for that mod to be completed (watching the original russian forum post like a hawk). I prefer the jagdtiger+ engine sounds, though. Anywho, make sure for testing this that you renamed ONLY the FEV file. The fsb must be left un-renamed because the FEV refers to it as its unchanged name. You only change the fev so the game uses it.

NoblePlatoon #8 Posted Mar 20 2012 - 11:55

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011

View Postanarchyxf36, on Mar 20 2012 - 06:13, said:

-1 cause the sounds didn't work even after renaming the files.
Uploaded late last night, and I named the file incorrectly, my mistake...but someone else could make it work. Clearly you don't understand the concept of "beta" and that this is a work in progress, although I laud your honesty...and, no, I won't give you a well-deserved neg (as opposed to the neg you gave me). Just please don't download any more of my mods until their are absolutely perfect. I promise to pm you each and every time I post a perfect mod. Heaven-forbid if you should have to suffer through my mistakes, or (gasp) if you have to offer valuable input in helping make a mod better.

I will rename the file, and re-upload. Still looking for more useful feedback as I work this mod out. If you don't have the time, patience or willingness to accept that this is a work in progress...then STAY AWAY from this mod. It is in BETA!

Yes, I am pissy. Have not had my coffee, and been working on this for several weeks. Wargaming does not offer a blueprint to go by...this modding is all trial-and-error.

EDIT: Removed harsh comments directed toward some not-to-be-named person.

FinnFann #9 Posted Mar 20 2012 - 17:51

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View PostNoblePlatoon, on Mar 20 2012 - 11:55, said:

Uploaded late last night, and I named the file incorrectly, my mistake...but someone else could make it work. Clearly you don't understand the concept of "beta" and that this is a work in progress, although I laud your honesty...and, no, I won't give you a well-deserved neg (as opposed to the neg you gave me). Just please don't download any more of my mods until their are absolutely perfect. I promise to pm you each and every time I post a perfect mod. Heaven-forbid if you should have to suffer through my mistakes, or (gasp) if you have to offer valuable input in helping make a mod better.

I will rename the file, and re-upload. Still looking for more useful feedback as I work this mod out. If you don't have the time, patience or willingness to accept that this is a work in progress...then STAY AWAY from this mod. It is in BETA!

Yes, I am pissy. Have not had my coffee, and been working on this for several weeks. Wargaming does not offer a blueprint to go by...this modding is all trial-and-error.

EDIT: Removed harsh comments directed toward some not-to-be-named person.

Whew. Remind me to keep clear of you before your morning coffee! XD I'm absolutely shocked, though, that he gave you a neg regarding this beta mod. I fully understood, even before trying it, that Wargaming is refusing to help anyone. I can kind of see why, as well. Removes them from responsibility if someone SOMEHOW uses a mod to cause legitimate trouble since they can just say it was all reverse engineered and out of their hands. In any case, I'll test the renamed engine files and update this post accordingly. That being said, I do still believe that the american engine sounds used by the M6 and the like need to be softened slightly as there's a very audible "Crunchyness" to the top of the sound thats slightly offputting. I'll be back shortly with confirmation that the rename worked!




EDIT: File not found error was reported by the download link. >.<

EDIT 2: Works now. Downloading.




NoblePlatoon #10 Posted Mar 20 2012 - 17:56

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011

View PostScyer, on Mar 20 2012 - 17:51, said:

EDIT: File not found error was reported by the download link. >.<
You caught me in a new re-upload. Please try again.

Terminus_Hostilia #11 Posted Mar 20 2012 - 18:00

    Staff sergeant

  • Players
  • 18946 battles
  • 273
  • [2K1LL] 2K1LL
  • Member since:
    02-27-2011

View Postanarchyxf36, on Mar 20 2012 - 06:13, said:

-1 cause the sounds didn't work even after renaming the files...

nah...not cool. This man is doing you a favor and he forewarned you that this was a test.


I honestly believe most people do not know how to use the rep system.


+1 for effort Noble. A personal thank you is in order for all your brain power spent on this.http://cdn-frm-us.wa...le_honoring.gif

FinnFann #12 Posted Mar 20 2012 - 18:01

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View PostNoblePlatoon, on Mar 20 2012 - 17:56, said:

You caught me in a new re-upload. Please try again.

Thought so. :) Downloaded, and found an error. You need to keep the fsb named "vehicle" because for some reason the FEV file is looking for that name. If its named "vehicles" like the fev is, then it won't work.

Likely something to do with when the FEV was compiled.



Terminus_Hostilia #13 Posted Mar 20 2012 - 18:04

    Staff sergeant

  • Players
  • 18946 battles
  • 273
  • [2K1LL] 2K1LL
  • Member since:
    02-27-2011
What was that loud growling noise I just heard? http://forum.worldof...e_veryhappy.gif

NoblePlatoon #14 Posted Mar 20 2012 - 18:42

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011

View PostScyer, on Mar 20 2012 - 18:01, said:

Thought so. :) Downloaded, and found an error. You need to keep the fsb named "vehicle" because for some reason the FEV file is looking for that name. If its named "vehicles" like the fev is, then it won't work.

Likely something to do with when the FEV was compiled.
That is what I was re-uploading (i.e. Fixed). See??? I need my coffee.  <_<

FinnFann #15 Posted Mar 20 2012 - 18:46

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View PostNoblePlatoon, on Mar 20 2012 - 18:42, said:

That is what I was re-uploading (i.e. Fixed). See??? I need my coffee.  http://cdn-frm-us.wa...ile_sceptic.gif
XD No problem. Although it still doesn't work. Your new upload has
vehicles.fsb
vehicles.fev

HOWEVER, It needs to be
vehicle.fsb
vehicles.fev

For it to work. ^.^;
And for goodness sakes, man, get the coffee DB

EDIT: Also good luck with getting help from Jafdet. I saw the post in the russian forum :)

Terminus_Hostilia #16 Posted Mar 20 2012 - 19:05

    Staff sergeant

  • Players
  • 18946 battles
  • 273
  • [2K1LL] 2K1LL
  • Member since:
    02-27-2011
That's strange..I got it to work with the files just like they were.
I will admit, it's not quite what I imagined, although it's also not horrible.

So, is it working as intended or not?

I hope not because the hissing noises are unbearable.

Going back to original files, for now anyway.

Best of luck Noble...I'm really anxious to hear them working right.

FinnFann #17 Posted Mar 20 2012 - 19:11

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View PostTerminus_Hostilia, on Mar 20 2012 - 19:05, said:

That's strange..I got it to work with the files just like they were.
I will admit, it's not quite what I imagined, although it's also not horrible.

So, is it working as intended or not?

I hope not because the hissing noises are unbearable.

Going back to original files, for now anyway.

Best of luck Noble...I'm really anxious to hear them working right.

Huh. Maybe it was just my game then. Try them renamed as I put it and tell me if you still hear them. ALSO Mute all except the tank sounds when testing. I noted that some other sound effects can sound an awwwful lot like an engine.

NoblePlatoon #18 Posted Mar 20 2012 - 19:24

    Captain

  • Players
  • 16690 battles
  • 1,944
  • Member since:
    05-24-2011

View PostScyer, on Mar 20 2012 - 18:46, said:

XD No problem. Although it still doesn't work. Your new upload has
vehicles.fsb
vehicles.fev

HOWEVER, It needs to be
vehicle.fsb
vehicles.fev
The originals are both vehicles. I no idea why your client uses vehicle.fsb. I suspect that your game client is still recognizing the original files, instead of the mod. There is no way vehicle should work. Even Jafdet uses vehicles, so I am not insane...maybe.  :Smile-playing:

View PostTerminus_Hostilia, on Mar 20 2012 - 19:05, said:

So, is it working as intended or not?
Don't you dare use Wargaming favorite phrase on me!!  :Smile-izmena:

View PostTerminus_Hostilia, on Mar 20 2012 - 19:05, said:

I hope not because the hissing noises are unbearable.
I don't hear any hissing. Could you describe which tanks you experience this from? Does anyone else experience hissing?

FreeFOXMIKE #19 Posted Mar 20 2012 - 19:26

    Major

  • Players
  • 18544 battles
  • 4,967
  • [23RDB] 23RDB
  • Member since:
    04-17-2011
thank you for your efforts

FinnFann #20 Posted Mar 20 2012 - 19:36

    Staff sergeant

  • Players
  • 20258 battles
  • 420
  • Member since:
    03-20-2011

View PostNoblePlatoon, on Mar 20 2012 - 19:24, said:

The originals are both vehicles. I no idea why your client uses vehicle.fsb. I suspect that your game client is still recognizing the original files, instead of the mod. There is no way vehicle should work. Even Jafdet uses vehicles, so I am not insane...maybe.  :Smile-playing:
Oddly it won't work for me unless I use vehicle.fsb instead of vehicles.fsb. With just vehicles, I get silence and only hear the ambient noises. With vehicle I get the engine sounds. Although vehicle CAN work depending on how the game looks for files. FEV tells the game what to look for and where, while FSB is just a sound bank, like a midi's instrument bank. So for some odd reason my system only works with the naming scheme "vehicle.fsb" and "vehicles.fev". I can provide video if needed, but I know I'm certainly not faking it given I turned everything but engine sounds off during this test @.@'''




If we had a third party other than us making sure of this, this'd help alot >.< That way we can confirm they're even hearing the engine noises. I only say this because I know some sound packs introduce ambient sounds that really do sound like an engine, and I even thought it was working for the first minute before I muted all but the engines. 






3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users