Jump to content


Equipment Purchasing Question


  • This topic is locked This topic is locked
3 replies to this topic

Swizsedtoast #1 Posted Nov 22 2012 - 02:19

    Captain

  • Players
  • 16090 battles
  • 1,251
  • Member since:
    10-07-2012
Hey guys, I'm looking to take advantage of the current and upcoming sales. I plan on buying a T34 after the 23rd as it will be 15% off, but I want to pre-purchase the equipment for it during this ongoing 50% off sale (which ends before the sale). I'm having trabu purchasing the equipment. When I go into store it only lets me choose equipment for my tanks that don't have equipment (in this case B1). The "All Vehicles" is greyed out and unselectable. Please and thanks very much for your help. If you need more info just ask!

Edited by Swizsedtoast, Nov 22 2012 - 02:20.


Necrophyle #2 Posted Nov 22 2012 - 02:25

    Sergeant

  • Players
  • 9242 battles
  • 223
  • Member since:
    03-14-2012
Are you sure you went to the store and not the depot, as I just checked it and is not grayed out?  Make sure you use the wiki to purchase the equipment specific to your tank.

Swizsedtoast #3 Posted Nov 22 2012 - 02:31

    Captain

  • Players
  • 16090 battles
  • 1,251
  • Member since:
    10-07-2012
I am looking at the Store Tab, under Equipment. "On vehicles" is checked but unchecking it lowers the available choices from 10 to 7. "My Vehicles" is checked and there appears to be no difference when "Compatable with" (B1) is checked. B1 is the only option on the drop-down list. Also, B1 is my only tank without full slots of equipment in my garage. "All vehicles" is greyed out.

I also have a KV4 which has the exact same equipment I want to purchase again. However, it doesn't give me the option to when I click on it's equipment in the garage. Only shows Demount or Destroy.
I believe I can obtain the extra equipment if I buy a tank of appropriate tier, buy the equipment, demount it with gold, and then sell the tank but it really isn't effective at all.

EDIT: My mistake, I also have a Cromwell with no equipment in the garage. However it does not appear on the drop-down list.

Edited by Swizsedtoast, Nov 22 2012 - 02:42.


Swizsedtoast #4 Posted Nov 22 2012 - 02:45

    Captain

  • Players
  • 16090 battles
  • 1,251
  • Member since:
    10-07-2012
Ok, thanks for your help. I figured it out. I had "France" under Nations selected under the drop-down list instead of "All Nations". Thread resolved!

Edited by Swizsedtoast, Nov 22 2012 - 02:45.





1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users