Jump to content


Launcher not opening game(Error 0xc0000022)

not able to open Launcher application

This topic has been archived. This means that you cannot reply to this topic.
10 replies to this topic

Orannis #1 Posted Dec 22 2012 - 03:07

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012
okay so ive been playing WoT for a few weeks and then suddenly today, i opened the launcher and it said"cannot open file, you may not have permissions"(this happened once before, but i figured it out) so just like the first time getting the game, we gave my windows account full access and full ownership and security access to the whole 'world of tanks' file. so then i tried it again, and the launcher popped up, it was odd because i usually need the admin password to actually get the launcher up. and after it finished checking for updates, i clicked play; and this message showed up: "The application was unable to start correctly (0xc0000022). click okay to close the application" so then i checked over the game file itself(not the launcher), and i saw that everything checked out; full security access and full ownership of file.

but the previous day there was a small update took maybe a minute or so to load. this may have done something.

anyone else have this problem?
anyone have solutions?
please help

bobjoeharris #2 Posted Dec 22 2012 - 03:20

    Staff sergeant

  • Beta Testers
  • 0 battles
  • 273
  • Member since:
    10-06-2010
Change your account to admin.

Orannis #3 Posted Dec 22 2012 - 03:23

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012

View Postbobjoeharris, on Dec 22 2012 - 03:20, said:

Change your account to admin.

and of course, over-protective parents will not allow this from assumptions that i will download something i don't want to and might destroy the system.

bobjoeharris #4 Posted Dec 22 2012 - 03:33

    Staff sergeant

  • Beta Testers
  • 0 battles
  • 273
  • Member since:
    10-06-2010
Ahh. Ok.

Orannis #5 Posted Dec 22 2012 - 03:45

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012

View PostOrannis, on Dec 22 2012 - 03:07, said:

okay so ive been playing WoT for a few weeks and then suddenly today, i opened the launcher and it said"cannot open file, you may not have permissions"(this happened once before, but i figured it out) so just like the first time getting the game, we gave my windows account full access and full ownership and security access to the whole 'world of tanks' file. so then i tried it again, and the launcher popped up, it was odd because i usually need the admin password to actually get the launcher up. and after it finished checking for updates, i clicked play; and this message showed up: "The application was unable to start correctly (0xc0000022). click okay to close the application" so then i checked over the game file itself(not the launcher), and i saw that everything checked out; full security access and full ownership of file.

but the previous day there was a small update took maybe a minute or so to load. this may have done something.

anyone else have this problem?
anyone have solutions?
please help

oh and great! now when the launcher comes up, it says that it 'cannot connect to update service' or something

Edited by Orannis, Dec 22 2012 - 03:45.


Orannis #6 Posted Dec 22 2012 - 03:53

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012
ugh and i don't want to have to reinstall the game, but if thats the only way to make it work then ill do it. but ugh i really, really dont want to have to wait 6+ hours for it to reinstall

Orannis #7 Posted Dec 25 2012 - 16:53

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012
ugh reinstalled the game... still has the error AND i cant get the launcher to pop up because the game is so intent on having you log in an administrator windows account.   uuuugh cmon WoT! 'y u need admin account?!' AND 'Y U NO FIX THIS SH*T'

Orannis #8 Posted Jan 13 2013 - 23:20

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012
Bump?

Aendaeron_Bluescale #9 Posted Jan 13 2013 - 23:33

    Captain

  • Players
  • 0 battles
  • 1,207
  • Member since:
    08-13-2011
Try reinstalling the game into %USERPROFILE%\World_of_Tanks instead.

%USERPROFILE% will point towards your user folder. Normally, you'll have full access privileges there.

Edited by Aendaeron_Bluescale, Jan 13 2013 - 23:35.


Orannis #10 Posted Jan 15 2013 - 01:45

    Captain

  • Players
  • 0 battles
  • 1,163
  • Member since:
    12-08-2012
tried, but still getting admin notice, and the error keeps coming up

Bump.

Spitfire50 #11 Posted Feb 08 2013 - 02:08

    Private

  • Players
  • 0 battles
  • 1
  • Member since:
    10-01-2012
I installed WoT on a new computer running Windows 7 and kept getting the same error message. I researched up and down before I finally found a solution (which isn't a good solution). I had to go into the Compatability area in the exe Properties and click "Run as administrator". Here's the funny thing...the error was coming up on two accounts, the one for my kids (a Standard User account) and the one for my husband (an Administrator account). Once ticking the "Run as Administrator" box my husband's account didn't have any problems launching WoT, but my kids' account required that I enter MY administrator password before launching. So what's the point of allowing "Run as Administrator" if the Administrator password is still required??? I ended up having to change the kids' account to Administrator (which is terribly frustrating just to run a game) so that they wouldn't be prompted for my password. I didn't have this problem in Windows XP, so I'm guessing Microsoft has done something idiotic with system security. If this is anything that the WoT creators can fix, that would be great.