Jump to content


Major FPS drops after 8.2


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

TooDigital #1 Posted Dec 29 2012 - 11:56

    Private

  • Players
  • 676 battles
  • 1
  • Member since:
    10-06-2012
Hey guys so I recently heard that AMD, ATI Graphic cards got improvements and lots of HIGH FPS. Well I have a NVIDIA Card myself, A
ZOTAC GTX 560m 2GB and while I was playing before 8.2 I got 50-120 FPS. Now days I get 40-90 FPS? Anyone have suggestions to fix this problem or anything saying that they are going to fix this problem. MY GRAPHIC CARD IS UPDATED

_Omega #2 Posted Dec 29 2012 - 12:10

    Staff sergeant

  • Beta Testers
  • 12843 battles
  • 262
  • Member since:
    08-06-2010
host client is the bad factor affecting fps and ms/lag  always has.. need new uptodated hosting..untill then glck ..

Clash_12 #3 Posted Dec 29 2012 - 12:17

    Sergeant

  • Players
  • 10571 battles
  • 123
  • [NZ-T] NZ-T
  • Member since:
    09-24-2012
I got a Nvidia 9800 GT 512mb so i get round 30 to 60 fps and i've only got worse ping form 230 to 260 (i live in New Zealand), but no difference for me in frames.

It might be your graphics card having to render more things hence the new rendering of maps.

RepentBeSaved #4 Posted Dec 29 2012 - 12:25

    Private

  • Players
  • 40503 battles
  • 3
  • Member since:
    11-13-2011
FPS drop for me too.  Same typical scenarios.  Zoom to sniper and nearly 5FPS for 2 seconds.  Fun.  My guess is not graphics card config, but can only be fixed in next rev.  My Pentium 4 3.6GHz/ NVidia 550TI struggles enough with min settings.

SdKfz_181 #5 Posted Dec 29 2012 - 13:04

    Corporal

  • Players
  • 4485 battles
  • 32
  • Member since:
    06-12-2011
Does it really matter unless it drops below 30 since anything higher is pointless?

scout_in_da_house #6 Posted Dec 29 2012 - 14:32

    Major

  • Players
  • 25887 battles
  • 2,485
  • [IOC_5] IOC_5
  • Member since:
    04-14-2012
honestly, why do you need more than 40fps? my average is probably around 20...
better start complaining when it falls under 10 ;)

Aendaeron_Bluescale #7 Posted Dec 29 2012 - 16:54

    Captain

  • Players
  • 6386 battles
  • 1,207
  • Member since:
    08-13-2011
Anything above your monitor frequency is redundant and dropped imagery data anyway.

UrghAvenger #8 Posted Dec 29 2012 - 21:04

    Sergeant

  • Players
  • 24318 battles
  • 148
  • Member since:
    10-24-2011

View PostSilentServant, on Dec 29 2012 - 12:25, said:

FPS drop for me too.  Same typical scenarios.  Zoom to sniper and nearly 5FPS for 2 seconds.  Fun.  My guess is not graphics card config, but can only be fixed in next rev.  My Pentium 4 3.6GHz/ NVidia 550TI struggles enough with min settings.

I've been having same problem since 8.2 came out. My fps is normally higher though, like 30fps. But when zooming, I lose about 10fps or so, for a few seconds. On some maps, and some situations, when my fps is already down to about 20fps, having my fps go down to 15 or less for a moment is a killer.

This problem does seem to go away after maybe 20 battles. Sometimes I can also exit and restart the game a few times to make it go away. I did work with support to try to fix this but couldn't solve the problem. I should probably get a better graphics card, which will probably require a better power supply.