Jump to content


8.5 Update Error Fix


This topic has been archived. This means that you cannot reply to this topic.
50 replies to this topic

Lincoln2011 #1 Posted Apr 25 2013 - 19:25

    Corporal

  • Players
  • 8953 battles
  • 18
  • [DP] DP
  • Member since:
    04-11-2011
I tried to update, like many others today, to 8.5 and also received the HTTP error.  The logs as reported by others were useless.  However, past history with the game says that at times pre-patch patch files can be an issue.

So, without further delay, try the following:

1. Go to your World_of_Tanks directory and open the Updates folder.
2. Find any file listed as "wot_85.####_client patch"
3. Delete these files.
4. Restart the launcher.  It will download good versions and patch/install.
5. Send praise and adoration or gold to me.  Thank you and good luck tankers!

GarettLou #2 Posted Apr 25 2013 - 19:35

    Corporal

  • Players
  • 13712 battles
  • 83
  • [HBG] HBG
  • Member since:
    01-07-2013
Is this the error you are talking about? Everytime I try to update my game it gives me this message

Updating game client:
Critical error.
Failed to install updates.
The application cannot continue.
For details, see log file.

I also tried to uninstall completely and downloaded the full 8.5 pack, but when I was extracting the files it was giving me errors each time with a certain file, with the option to try again or skip.
I can't figure out what's going on, any help would be awesome. I have a i7 with windows7.

Boriswar #3 Posted Apr 25 2013 - 19:44

    Captain

  • Players
  • 17247 battles
  • 1,193
  • [PLSGO] PLSGO
  • Member since:
    07-07-2011
its broken for me as well, same error

Critical error
failed to download updates via HTTP
the application cannot continue
for details, see log file


this is the first time I've ever had this problem in almost 2 years of playing the game

and this didnt fix anything about it btw

Edited by Boriswar, Apr 25 2013 - 19:49.


Bullick #4 Posted Apr 25 2013 - 19:49

    First lieutenant

  • Players
  • 10444 battles
  • 639
  • Member since:
    03-24-2011
"My login packet sent to the server is malformed. Probably your application is out of date or corrupted,"  ???????

Squeesher #5 Posted Apr 25 2013 - 19:56

    Corporal

  • Players
  • 22608 battles
  • 71
  • [-NWO-] -NWO-
  • Member since:
    04-19-2011
I had the first error about HTTP failure to download about halfway through the update. Restarting the launcher was all I had to do. I didn't delete the progress I had already made in the download, it just picked it back up where it left off.

Ubuntu #6 Posted Apr 25 2013 - 21:31

    First lieutenant

  • Players
  • 23757 battles
  • 583
  • Member since:
    09-06-2011
I get this error:

Quote

25/04/2013 16:28:55 http request(id = 1): response info: status=403, error=0, content_len=88

Fix webserver permissions please!

Edited by Ubuntu, Apr 25 2013 - 21:31.


Prophet_of_Death #7 Posted Apr 25 2013 - 21:51

    Captain

  • Players
  • 24502 battles
  • 1,058
  • Member since:
    01-05-2013
I had the same problems and nothing customer support has been able to say or do has helped anything. I still recieve the same messages so again for the fourth time today I have completly removed all WoT files from my system and will try to redownload the game again although I must say I;m not convinced it will do anything.

KCDestroyer #8 Posted Apr 25 2013 - 22:07

    Corporal

  • Players
  • 7636 battles
  • 42
  • Member since:
    10-24-2012
Didn't work.....still can't install update after trying everything for hours. I used to get thru 47% of update....now I don't get through any before the error...

Griffon327327 #9 Posted Apr 25 2013 - 22:55

    Sergeant

  • Players
  • 33219 battles
  • 125
  • Member since:
    10-20-2012
going to consider another hobby started to update at 9;00 am here it is now 5:39  8.5 hours later at 99% of update... tried to just download the update itself directly with no issues and then manually install it ... did not work tried to download the complete game from the site without using the stupid torrent site and only took 23 min for 4.5 gigs versus the 8 hours for 267 mb udate .. the complete game in rar file cannot be extracted because of errors..
so to recap almost 9 hours updating and still not done ...

_Platform #10 Posted Apr 25 2013 - 23:02

    Staff sergeant

  • Players
  • 9013 battles
  • 329
  • [REL-V] REL-V
  • Member since:
    03-07-2012

Quote

25/04/2013 17:55:56 Patch installation...
25/04/2013 17:55:56 pkg file(id = 1): name="wot_85.2492_client.patch", size=1726465741, uncompressed_size=3836426385
25/04/2013 17:55:56 pkg file(id = 2): name="wot_85.2493_85.2492_client.patch", size=3415020816, uncompressed_size=5753359359
25/04/2013 17:55:56 pkg file(id = 3): name="wot_85.2535_85.2493_client.patch", size=5414694, uncompressed_size=16744863
25/04/2013 17:56:08  ERROR: pkg file(id = 1): what="extract file error", msg="name="C:\Games\World_of_Tanks\Updates\wot_85.2492_client.patch" file="res\packages\vehicles_american.pkg" to="C:\Users\Jared\AppData\Local\Temp\wargaming.net\wot\temp\wot_85.2492_client.patch""
25/04/2013 17:56:08  ERROR: pkg file(id = 1): FAIL
25/04/2013 17:56:08  ERROR: Patch installation: FAIL


It seems the wot_85.2492_client.patch is bad, but I've already tried re-downloading multiple times. Always the same error.

vanrove #11 Posted Apr 25 2013 - 23:18

    Private

  • Players
  • 13568 battles
  • 1
  • Member since:
    08-16-2011
I've tried everything including stopping my AV, clearing the update dir, reloading and so on, I still get stuck at around 65% with this error. I've been working on this for over 5 hours now....

MasterRanger #12 Posted Apr 25 2013 - 23:42

    Private

  • Players
  • 7271 battles
  • 5
  • Member since:
    04-21-2013
Same here.

Critical error
failed to download updates via HTTP
the application cannot continue
for details, see log file

As suggested i opened the World of Tanks folder located in the Games folder on my hard drive. then opened the Updates folder and deleted all  wot_85. files. Then opened the game launcer once again. The updates downloaded once again and this time it all installed without a hitch. A far cry from having to download the full game all over again. Either the patch must be on a weak server or you may have had program's running in the background that corrupted the download such as security scan or antivirus. Hopefully this helps somebody. Good Luck

junker54 #13 Posted Apr 26 2013 - 00:53

    Corporal

  • Players
  • 8093 battles
  • 11
  • [MDG] MDG
  • Member since:
    08-30-2012
I also had error message when trying to update to 8.5

What I did was manually download the 8.5 patch. Go into WOT program/updates. Delete anything with wot_ 8.5  and then drag the manually downloaded file into updates. Worked for me.

RiotingVirus #14 Posted Apr 26 2013 - 00:59

    Private

  • Players
  • 20702 battles
  • 4
  • Member since:
    03-29-2011
tried what Lincoln said, to no avail I will try what you did junker

KommandantVonSchnitzel #15 Posted Apr 26 2013 - 01:02

    Private

  • Players
  • 384 battles
  • 3
  • Member since:
    11-03-2012

View PostSqueesher, on Apr 25 2013 - 19:56, said:

I had the first error about HTTP failure to download about halfway through the update. Restarting the launcher was all I had to do. I didn't delete the progress I had already made in the download, it just picked it back up where it left off.
EDIT*

Nevermind.

It works by magic now.

Edited by KommandantVonSchnitzel, Apr 26 2013 - 01:03.


RiotingVirus #16 Posted Apr 26 2013 - 01:04

    Private

  • Players
  • 20702 battles
  • 4
  • Member since:
    03-29-2011
Got it working good call junker on that bud

jellisjuice #17 Posted Apr 26 2013 - 01:05

    Private

  • Players
  • 695 battles
  • 1
  • Member since:
    03-08-2013
I was having the same issue.  I tried deleting the 8.5 update files, but that didn't help either.  I went into my res_mods/0.8.4 folder and deleted everything within.  Now, the update seems to be downloading fine.  I still haven't reached the 50% mark, so I'm not sure if that solved the issue.

*will update

*update

Did not work at all.  I made it to about 15% and got the same critical error.  I have tried every combination of deleting update files, restarting....deleting update files, restarting client.  Nothing seems to be working.  I am currently manually downloading the 8.5 update to see if that works.  If it doesn't, I will uninstall the game and install from scratch.

*More updates to come

Edited by jellisjuice, Apr 26 2013 - 01:27.


tommyhawk101 #18 Posted Apr 26 2013 - 01:18

    Corporal

  • Players
  • 19755 battles
  • 31
  • [ARRG] ARRG
  • Member since:
    07-22-2011
id like to try junkers idea but the manual link to update only just clicks no server side response


ChickenMcFuggits #19 Posted Apr 26 2013 - 01:20

    Major

  • Players
  • 20660 battles
  • 2,763
  • Member since:
    02-12-2012

View PostBullick, on Apr 25 2013 - 19:49, said:

"My login packet sent to the server is malformed. Probably your application is out of date or corrupted,"  ???????
Mine was, so I closed and reopened the client. Worked normal after that.

General_Vicinity #20 Posted Apr 26 2013 - 01:22

    Corporal

  • Players
  • 31822 battles
  • 80
  • [2HARM] 2HARM
  • Member since:
    04-07-2012
6 hours of trying to install 8.5 and still no go.

I've tried every suggestion on the forum.

I really enjoy WoT . .  .  but only when I get to play.