Jump to content


Temporary fix for XVM crash (garage crash)


This topic has been archived. This means that you cannot reply to this topic.
28 replies to this topic

Tankthief #1 Posted Nov 01 2013 - 16:05

    First lieutenant

  • Players
  • 10960 battles
  • 913
  • Member since:
    03-05-2012
Found a solution for my by deleting all hangar.xc from XVM folder.

search: hangar.xc > delete

Gryphon_ #2 Posted Nov 01 2013 - 16:16

    Captain

  • Players
  • 19953 battles
  • 1,149
  • [COD] COD
  • Member since:
    11-24-2011
I just renamed my hangar.xc to -hangar.xc, which disables it. Once the Halloween garage is gone, I'll rename it back.
Its better to rename files rather than delete them.

UPDATE - the above doesn't fix it
Renaming res_mods/8.9/gui/flash/Application.swf to res_mods/8.9/gui/flash/-Application.swf seems to work
Adding the '-' to the filename disables it.

Edited by Gryphon_, Nov 01 2013 - 16:59.


beepybeetle #3 Posted Nov 01 2013 - 16:19

    Sergeant

  • Players
  • 16592 battles
  • 245
  • [CMCAW] CMCAW
  • Member since:
    05-21-2011
XVM crashes the garage?

reese342 #4 Posted Nov 01 2013 - 16:20

    First lieutenant

  • Players
  • 6764 battles
  • 912
  • [ERAD] ERAD
  • Member since:
    03-13-2011
Don't want crashes?
-Don't use XVM.

Vipsanius #5 Posted Nov 01 2013 - 16:26

    Corporal

  • Players
  • 11615 battles
  • 70
  • Member since:
    01-01-2013
Don't want to be involved in a car jack?
-Don't drive.

nipp100 #6 Posted Nov 01 2013 - 16:32

    First lieutenant

  • Players
  • 32145 battles
  • 798
  • [BULBA] BULBA
  • Member since:
    06-13-2011
Hoping this works, its very annoying being DC'ed every 3-4 games or so.. and is anyone else´s XVM not working like 95% of the time too? i´ve installed the 5.0.1-test2 and like i said it only works in like 5%~ of the time.
It worked for me, thanks bro  :playing:

Edited by nipp100, Nov 02 2013 - 01:35.


AgentFowler #7 Posted Nov 01 2013 - 16:51

    Corporal

  • Players
  • 7921 battles
  • 84
  • [O-B-G] O-B-G
  • Member since:
    08-20-2013
For the LOVE OF GOD, I crash EVERY GAME. Ugh

gman2725 #8 Posted Nov 01 2013 - 17:12

    Staff sergeant

  • Players
  • 9668 battles
  • 457
  • Member since:
    04-28-2011

View Postnipp100, on Nov 01 2013 - 16:32, said:

Hoping this works, its very annoying being DC'ed every 3-4 games or so.. and is anyone else´s XVM not working like 95% of the time too? i´ve installed the 5.0.1-test2 and like i said it only works in like 5%~ of the time.

I think this is related to the move WG made to a new statistics API. The new API has a cap set on how many requests it can handle at a time and can cause updates to not come back when requested from the server.

CallmeAwe #9 Posted Nov 01 2013 - 19:06

    Sergeant

  • Players
  • 23748 battles
  • 100
  • [-TRN-] -TRN-
  • Member since:
    05-19-2012
I can confirm that renaming res_mods/0.8.9/gui/flash/Application.swf has fixed my leaving battle client crashes. I renamed mine to Application_backup.swf, but the name doesn't matter as long as it is changed.

H8M3 #10 Posted Nov 01 2013 - 19:10

    Major

  • Players
  • 9082 battles
  • 2,079
  • [H8] H8
  • Member since:
    04-27-2012
i went to the source. and downloaded version 1904 where they fixed the issue.. but they diddnt put it in build 1905 and up for some reason
changes list https://code.google....xvm/source/list
corresponding "fix" http://download-xvm....vm_flex4.10.zip
ok that diddnt work..
ill try the above mentioned method n see what happens

Edited by H8M3, Nov 01 2013 - 19:17.


bailey4500 #11 Posted Nov 01 2013 - 19:28

    Corporal

  • Beta Testers
  • 10376 battles
  • 42
  • [2ACR] 2ACR
  • Member since:
    01-27-2011

View PostCallmeAwe, on Nov 01 2013 - 19:06, said:

I can confirm that renaming res_mods/0.8.9/gui/flash/Application.swf has fixed my leaving battle client crashes. I renamed mine to Application_backup.swf, but the name doesn't matter as long as it is changed.

I can confirm this worked for me as well.

H8M3 #12 Posted Nov 01 2013 - 19:32

    Major

  • Players
  • 9082 battles
  • 2,079
  • [H8] H8
  • Member since:
    04-27-2012

View Postbailey4500, on Nov 01 2013 - 19:28, said:

I can confirm this worked for me as well.
yeah it works so far.. only thing i see that it shut off is the mirror for battle loading. can anyone else see anything else it messes up?

jsh0602 #13 Posted Nov 01 2013 - 20:11

    Captain

  • Players
  • 9282 battles
  • 1,025
  • [-RM-] -RM-
  • Member since:
    02-13-2013
Ill try this web I get off work.

ScreeminDemon #14 Posted Nov 01 2013 - 20:19

    Private

  • Players
  • 14189 battles
  • 9
  • Member since:
    01-10-2013
After renaming the application.swf file, Instead of crashing outright(the game just closing), it now just doesn't let me exit the battle and get back to my garage, even after it's over.

Ceptyr #15 Posted Nov 01 2013 - 21:58

    Sergeant

  • Beta Testers
  • 12018 battles
  • 187
  • [THUGZ] THUGZ
  • Member since:
    12-29-2010
Removing/renaming Application.swf affects the display of the server pings, showing platoon tiers, and the "move best crew" function. Thats it as far as I've found so far. Game doesn't seem to crash (played 30 battles or so).
Another possible solution instead of renaming that file is to do the following (source):
1. Edit login.xc (if you use a default config)
2. Find "enabled": true,
3. Change to "enabled": false,
4. Save
If you use a custom config where everything is in one file, open your xvm.xc file and look for this section:
"hangar": {
"hideTutorial": true,
"pingServers": {
  "alpha": 80,
  "columnGap": 10,
  "delimiter": ": ",
  "enabled": true,
  "fontStyle": {
Change true to false and save the file. Some values might differ in your config, but changing the enabled line is all you need to do. Can anyone confirm if this works for them? Been working for me so far.

Edit: Pingservers isn't the issue. Only thing that's actually worked for me long-term is removing application.swf.

Edited by Ceptyr, Nov 02 2013 - 01:49.


H8M3 #16 Posted Nov 01 2013 - 22:04

    Major

  • Players
  • 9082 battles
  • 2,079
  • [H8] H8
  • Member since:
    04-27-2012
ok i took application from test one added it to test 2 and so far no crashes,, http://www.mediafire...Application.swf

please report back

Ceptyr #17 Posted Nov 02 2013 - 00:21

    Sergeant

  • Beta Testers
  • 12018 battles
  • 187
  • [THUGZ] THUGZ
  • Member since:
    12-29-2010
H8M3, I tried that (moving Test 1 Application.swf into Test 2) and started receiving crashes again. Exiting a battle before it finished did not result in a crash, only after the battle was complete and all enemy tanks were killed.
Edit1: Looks like the game servers are under maintenance? Might be why I got, kicked at the end. Will try to reproduce with no changes.
Edit2: Game continues to crash after battles every 3-4 games.

Edited by Ceptyr, Nov 02 2013 - 00:55.


TurboT #18 Posted Nov 02 2013 - 00:24

    Staff sergeant

  • Players
  • 27621 battles
  • 336
  • [BOSS] BOSS
  • Member since:
    03-01-2011

View PostH8M3, on Nov 01 2013 - 22:04, said:

ok i took application from test one added it to test 2 and so far no crashes,, http://www.mediafire...Application.swf

please report back

I did the same thing, got a crash first try.  I will be removing all mods until this is sorted and try it mod free for a while.

Maggz #19 Posted Nov 02 2013 - 01:20

    First lieutenant

  • Players
  • 25208 battles
  • 832
  • [-TRN-] -TRN-
  • Member since:
    12-02-2011
These crash issues from what numerous people have reported are not limited to users of XVM. This is a game client issue not XVM. granted there are other cases that xvm can cause a crash, but for the most part this should not be the reason people are crashing during battles. Unfortunatly for the most part, the people who post on this thread are xvm users. so it gets lumped into this pile.

muswp1 #20 Posted Nov 02 2013 - 01:35

    Staff sergeant

  • Players
  • 23746 battles
  • 366
  • [PDL] PDL
  • Member since:
    08-29-2011
I'm not sure if it's related, but Sunday the SEA server is getting a 8.9.2 micropatch.