Jump to content


Repair Kits


  • This topic is locked This topic is locked
5 replies to this topic

Chadwiick #1 Posted Mar 25 2011 - 20:48

    Staff sergeant

  • Beta Testers
  • 6675 battles
  • 321
  • Member since:
    12-14-2010
Great... now it's when I use a repair kit my tracks get damaged even further!
I was in a battle, got tracked, used the repair kit and destroyed the track!

RA6E_ #2 Posted Mar 25 2011 - 21:01

    Captain

  • Beta Testers
  • 17402 battles
  • 1,657
  • Member since:
    12-23-2010
Man.....Small repair kit (3K one) only repairs module for three minutes..then it returns to its damaged state............:blink:

Clockworkred #3 Posted Mar 25 2011 - 21:19

    Captain

  • Beta Testers
  • 16364 battles
  • 1,997
  • [LBAS] LBAS
  • Member since:
    07-19-2010
The small repair kit brings a module back to Undamaged from either a Damaged or Disabled state, except the small kit will wear off after 2 minutes and bring the module back to Damaged. Think of the small repair kit like duct tape, it'll work, but only for a while.

Gold repair kits repair the module back to Undamaged and will stay that way until the module is damaged again. Think of this more like superglue. It's not getting loose unless you kick it again.

TheDude101 #4 Posted Mar 25 2011 - 22:49

    First lieutenant

  • Beta Testers
  • 8893 battles
  • 803
  • [-BNP-] -BNP-
  • Member since:
    12-09-2010
Nothing better than using your consumable repair kit then 2 seconds later getting doule tracked...

Chadwiick #5 Posted Mar 26 2011 - 00:44

    Staff sergeant

  • Beta Testers
  • 6675 battles
  • 321
  • Member since:
    12-14-2010
Thanks for taking the time to read the post.
You couldn't of been any farther off.
When my tracked got destroyed it was within 5 seconds of getting hit, used, destroyed.

Scard21 #6 Posted Mar 26 2011 - 14:43

    Corporal

  • Beta Testers
  • 5467 battles
  • 61
  • [ECO] ECO
  • Member since:
    07-27-2010
i had a track get broke by hummel in last game just one track that is red the other track is WHITE, i useda repair kit while he reloading guess.. what therepair kit i guess failed all it did was made the track yellow and my track is white still good condition i guess i broke the wrench? WTH! :facepalmic: , and no else was around that had a clear shot of me from snipe position.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users