Jump to content


FIX - Alternative fix for zoomed fire fps drop.


  • This topic is locked This topic is locked
14 replies to this topic

mauser13 #1 Posted Mar 26 2011 - 21:04

    Sergeant

  • Beta Testers
  • 11400 battles
  • 244
  • Member since:
    11-13-2010
hey, recently my vga hd 5850 just died (its in a rma procedure now) .. and i had to use onboard video, ive noticed that when im sniping/zoomed and fire my fps drops to something like 5, which is very annoying... i started to dig for a solution, and after updating my onboard video driver ( its a ati hd 4290) nothing happened.
here on forum ive downloaded an low detail graphis files, but i felt confortable with my current graphics the problem was, firing when zoomed, so..

EDIT:
actually you can just add a character to each of these 3 files
[ shot_main.xml / shot_mb_main.xml / shot_mb_small.xml ]
so they wont be found by the game and wont execute and so no lag.
I simple added a 'underline' before the file names.. so its looks like that now
[ _shot_main.xml / _shot_mb_main.xml / _shot_mb_small.xml]

thanks goes to 'SKurj'
Posted 22 April 2011 - 01:33 PM
AN option Corsac is just rename the files in C:\Games\World_of_Tanks_closed_Beta\res\particles\Tank'


i dont think its going to be needed, but feel free to make questions.
cya

JFigueiredo #2 Posted Mar 26 2011 - 23:49

    Corporal

  • Beta Testers
  • 19880 battles
  • 12
  • Member since:
    07-07-2010
Thx mauser, this worked very fine for me!

Simple solution.

darknothing #3 Posted Mar 27 2011 - 04:48

    Sergeant

  • Beta Testers
  • 4595 battles
  • 160
  • Member since:
    10-09-2010
works very good,

SKurj #4 Posted Mar 29 2011 - 19:28

    Captain

  • Beta Testers
  • 13512 battles
  • 1,292
  • Member since:
    09-05-2010
I just renamed all those files with "shot" in them, works well.

stormofjustice9 #5 Posted Apr 01 2011 - 04:01

    Corporal

  • Beta Testers
  • 10409 battles
  • 34
  • Member since:
    09-23-2010
Thus far it has worked for me, thanks a lot and good job!

Tree_Fox #6 Posted Apr 21 2011 - 23:57

    Private

  • Players
  • 1151 battles
  • 4
  • Member since:
    03-20-2011
The download item seems to have been moved or something. COuld you please reupload it?

SKurj #7 Posted Apr 22 2011 - 12:33

    Captain

  • Beta Testers
  • 13512 battles
  • 1,292
  • Member since:
    09-05-2010
AN option Corsac is just rename the files in C:\Games\World_of_Tanks_closed_Beta\res\particles\Tank

Rename any file with "shot" in it, just add a character to the file name should you want to put them back later.

MerryPrankster #8 Posted Apr 23 2011 - 23:06

    First lieutenant

  • Beta Testers
  • 8991 battles
  • 567
  • [OCB] OCB
  • Member since:
    12-01-2010
THANK YOU SOOOOO MUCH!! This fix works wonders!

Mods you should make this a sticky asap!

Mizar_Panzer #9 Posted May 20 2011 - 09:20

    Major

  • Beta Testers
  • 3789 battles
  • 2,421
  • [TT-C] TT-C
  • Member since:
    09-15-2010
Having trouble with zoomed fire lag too, it kinda hinders me from sniping properly. Will give this a try.

cobaltRain #10 Posted May 29 2011 - 03:45

    Corporal

  • Players
  • 10614 battles
  • 38
  • Member since:
    04-30-2011
Finally!!!

I tried the compatibility mode fix and replacing the .swf for the 1st person view but neither worked. Would go from ~60fps to single digits when firing in first person view. Now I there isn't as much as a single frame drop when shooting. This is using a 27" iMac core i5 760 2.8ghz, 12gb DDR3 and Radeon 5750 1gb though bootcamp.

Thanks!

Artyom_2033 #11 Posted Jul 12 2011 - 06:01

    Sergeant

  • Players
  • 9219 battles
  • 130
  • Member since:
    06-15-2011
I get this problem too, what do the files mentioned do? If this is an issue shouldn't the devs fix it? I always get a lag out when I fire my gun zoomed in for some reason.

SKurj #12 Posted Jul 14 2011 - 18:40

    Captain

  • Beta Testers
  • 13512 battles
  • 1,292
  • Member since:
    09-05-2010

View PostArtyom_2033, on Jul 12 2011 - 06:01, said:

I get this problem too, what do the files mentioned do? If this is an issue shouldn't the devs fix it? I always get a lag out when I fire my gun zoomed in for some reason.

Its the smoke etc when firing your gun that causes the slow down when zoomed.  By renaming or removing the files, you don't get the framerate hit.

5150warpig #13 Posted Jul 14 2011 - 21:51

    Staff sergeant

  • Players
  • 39477 battles
  • 400
  • Member since:
    03-07-2011
one of those files with shot in it is for tracers. i dont remember witch one it is but if u rename it u will not get tracers

CheeseW01f #14 Posted Jul 24 2011 - 13:05

    Private

  • Beta Testers
  • 0 battles
  • 2
  • Member since:
    01-14-2011
Wow, you saved me a lot of frustration buddy, thanks a bunch. And a piece of advice to everyone else, if this fix doesn't solve your problem completely try combining renaming the files mentioned in this thread with the instructions found in THIS THREAD. +1 from me

Sparky630 #15 Posted Jul 27 2011 - 16:34

    Staff sergeant

  • Beta Testers
  • 4940 battles
  • 304
  • Member since:
    07-18-2010
goood thread, they should really sticky this  :Smile_great:




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users