Jump to content


[1.4.0] XVM Config by Bones (6Feb19)

XVM WN8 Minimap DamageLog HP in Player Panel carousel tank carousel Battle Results zoom 1.4.0

  • Please log in to reply
341 replies to this topic

Stopple #241 Posted Dec 16 2015 - 19:33

    Private

  • Players
  • 8258 battles
  • 1
  • [HKA] HKA
  • Member since:
    12-01-2013
I'm not seeing a log of received damage (shell type, from who) - did I break something or is it not included anywhere?

Bones #242 Posted Dec 16 2015 - 23:27

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

You're not blind and you didn't break anything. XVM doesn't yet have a received damage log, only an inflicted damage log. (But if they ever do add that feature in, I'll include it in this config.)

 

For now you'll need to download a separate damage log mod. Personally, I like GambitER's damage log. You can find it here on the EU forums



19GotMitUns42 #243 Posted Dec 18 2015 - 02:55

    Private

  • Players
  • 18580 battles
  • 7
  • Member since:
    01-09-2014
The green currently spotted/ orange unspotted indicator dots are not showing up for me, is there a config to turn them back on?

edit: Fixed it by deleting my XVM fonts.

Edited by 19GotMitUns42, Dec 18 2015 - 03:29.


oochycoo #244 Posted Dec 26 2015 - 00:53

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

Im not seeing the spotted indicators on the enemy team panel - did look for the xvm fonts but nothing seemed obvious - what am I missing?

 

thanks in advance for any assistance - and Merry Christmas everyone



Bones #245 Posted Dec 27 2015 - 21:04

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

View Postoochycoo, on Dec 25 2015 - 17:53, said:

Im not seeing the spotted indicators on the enemy team panel - did look for the xvm fonts but nothing seemed obvious - what am I missing?

 

Well, just to verify, you are using one of the two configs that ISN'T the "no stats" version?

 

In the middle of the battle, can you hit the TAB button to bring up the statistics form, and do the spotted markers show up there?

 

Can you give me a screenshot of what you're seeing?

 

Up to this point, everyone who has had problems with the enemy spotted markers had those issues because they had old XVM fonts installed on their machine (many times without their knowledge - as an example, OMC Modpack was installing those behind the scenes until very recently).

 



oochycoo #246 Posted Dec 29 2015 - 00:04

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

 

Im using the middle one

 

 

 

 

 

 

 

 

 

Bones XVM Config (w/WN8 & HP in Player Panels)

 

the tab option does show the spotted marker - I just don't see them in the player panel like I used too

I wasn't sure what to delete to remove the xvm fonts

 

 

 

 

 

 

 

 

 

 

 

 


Edited by oochycoo, Dec 29 2015 - 00:18.


Bones #247 Posted Dec 30 2015 - 20:56

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Hmm... okay, if you see the spotted markers in the TAB screen but not in the players panel, it's not a font issue.

 

So, next step... what "size" of players panel are you displaying? In game (or in a replay), control-left click on the buttons at the top right just above the players panel. See if changing the display makes any difference.



oochycoo #248 Posted Dec 31 2015 - 01:58

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

I run with the panels on the full option (iv) but I don't see the spotted markers in any of the other settings either - the only other mod I have loaded is the received damage announcer - so hard to see how that might interfere.

Is there an option in the config somewhere to alter their appearance - maybe I should try that?


 

thanks for your help on this as well :)


 



jfmartel #249 Posted Jan 09 2016 - 03:51

    Corporal

  • Players
  • 14110 battles
  • 33
  • Member since:
    02-26-2013
Imnot seeing anymore the icon in the damage log when I kill someone or ammorack. Whats wrong? Using xvm latest version.

oochycoo #250 Posted Jan 30 2016 - 17:53

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

View Postoochycoo, on Dec 31 2015 - 01:58, said:

I run with the panels on the full option (iv) but I don't see the spotted markers in any of the other settings either - the only other mod I have loaded is the received damage announcer - so hard to see how that might interfere.

Is there an option in the config somewhere to alter their appearance - maybe I should try that?


 

thanks for your help on this as well :)


 

 

got it working now - not entirely sure what happened but i migrated to a SSD - so something got cleared out.

My new question though is how to get dead enemy/allies tanks to show on the minimap

 

seems like it might be useful to know

thanks for taking your time to develop this config Bones - its really great and much appreciated!

 



jfmartel #251 Posted Jan 31 2016 - 07:59

    Corporal

  • Players
  • 14110 battles
  • 33
  • Member since:
    02-26-2013

View Postjfmartel, on Jan 08 2016 - 21:51, said:

Imnot seeing anymore the icon in the damage log when I kill someone or ammorack. Whats wrong? Using xvm latest version.

 

Damn XVM Windows font! :P Deleted the XVM fonts in the c:\Windows\Font directory and got it fixed...

Bones #252 Posted Mar 10 2016 - 18:40

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 10 MARCH:

 

Upgraded to XVM 6.2.1, nightly build 5218 for WoT 0.9.14.

 

Other than changes/additions to the vehicles names file, there were minor changes to config files and more stable functionality within the mod.

 

As always, if you have any issues, report them here and I will do my best to help you out.

 

Good tanking!



Bones #253 Posted Mar 22 2016 - 21:35

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 22 MARCH:

 

Upgraded to XVM 6.2.1.1 build 5290.

 

This includes a few changes, including a fix to the display of the number of players online on each server, some updates to the XVM sound catalog, and the ability to display the total HP pools of each team (disabled by default; can be activated by editing battle.xc).

 

Good tanking!



Bones #254 Posted Apr 01 2016 - 19:38

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 1 APRIL:

 

Updated to XVM 6.2.1.2 build 5326 for WoT 0.9.14.1.

 

Not much new, but users DEFINITELY need to update to the latest XVM build to be able to play the current version. The only problem I'm seeing so far is that the April Fools tank name didn't make it into this current build. I'll update that as soon as I see a fix.

 

 

Good tanking!



Bones #255 Posted May 25 2016 - 16:47

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 25 MAY 2016:

 

Updated to XVM 5.3.0.1 build 5667 for WoT 0.9.15

 

At this point, this is a simple update to the new build for the latest game patch. As I dig in to the changes, I will post additional updates with new features or upgrades.

 

As always, report any bugs or issues here and I will do my best to fix them.

 

 

Good tanking!



LadyAtlas777 #256 Posted Jun 02 2016 - 16:29

    Private

  • Players
  • 11507 battles
  • 8
  • Member since:
    01-17-2013
Thank you for doing this config. I've been using it for a year at least. I love it. <3

Bones #257 Posted Jun 16 2016 - 02:02

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 15 June:

 

Apologies for taking so long, but update for WoT  0.9.15.1 is now live - in the form of XVM 6.3.2, build 5784.

 

Good tanking!



Bones #258 Posted Jul 29 2016 - 19:19

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Am I planning on publishing an updated XVM config?

 

Short answer: Yes.

 

The problem is, with WG's move to AS3, the XVM devs rewrote a SIGNIFICANT amount of the code (and parts of the app are still not functional, like the minimap and multi-lined carousel). I am slowly hacking together a config that works, but it is not pretty and is nowhere near ready for release. Unfortunately, a lot of the fixes are a line-by-line trial-and-error process. I'm getting there, albeit slowly.

 

For now, you can download XVM for 0.9.15.1 build 6096, which is their newest stable build, and install that. If you have my config already installed, it will work, but be forewarned: it is not pretty to look at. 

 

So far, I have noticed that these features of XVM do not function:

Minimap (specifically and most noably the range circles and lines on the map)

Multi-Lined Carousel

Using XVM with other graphic mods (such as crosshairs)

 

These are the problems with my config that I am in the process of fixing:

Player Panels

Over-target markers

Floating damage markers

Damage inflicted panel

 

These are the only other mods that I've been able to use alongside XVM:

White dead tanks (and tracks)

YasenKrasen Colored Messages

 

 

Stay tuned here for an update - I'm hoping to have something releaseable "soon."

 

Good luck and good tanking!



Bones #259 Posted Jul 30 2016 - 19:51

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Update 30 July:

 

Upated to XVM 5.4.0 build 6176 for WoT 0.9.15.1.

 

NOTE: With World of Tanks' move to AS3, many mods were "broken" and have to be rebuilt, XVM included. While many of XVM's features are now operational, not everything is fully functional. Of note: the XVM Minimap and Garage Carousel ARE NOT CURRENTLY OPERATIONAL Rest assured, as soon as those options are working again, I will update this config to make them operational. 
 
Also note - XVM seems to have conflicts with some newly updated mods. If your game/screen doesn't look right, delete everything from your res_mods folder and then begin testing by adding in one mod at a time, starting with XVM. 
 
As always, report any issues here and I'll do my best to work them out.
 
Good tanking!


Bones #260 Posted Aug 09 2016 - 19:08

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Update 9 August:

 

Upgraded to XVM 6.4.0 build 2154 for WoT 0.9.15.1.

 

This is the most current stable mod and makes some minor fixes/changes. Additionally, I've made some updates to the config files, most notably to the players panels to better display the information on-screen.

 

Note: The carousel and minimap are still NOT OPERATIONAL in this release. The XVM devs are working on both of those functions at the moment. The multi-line carousel looks to be nearly done, but the minimap is likely still weeks away from release. You can expect an update here as soon as there is a stable release that includes either function. 

 

Good tanking!






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users