Jump to content


[1.4.0] XVM Config by Bones (6Feb19)

XVM WN8 Minimap DamageLog HP in Player Panel carousel tank carousel Battle Results zoom 1.4.0

  • Please log in to reply
341 replies to this topic

wrenchn #261 Posted Aug 10 2016 - 03:54

    First lieutenant

  • Players
  • 58622 battles
  • 818
  • Member since:
    05-25-2013

WOW, did you just want to mess with our heads or is it just me....the kill number go from high to low now. So along with a PIA update now I have to retrain myself

 



Bones #262 Posted Aug 11 2016 - 16:22

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

View Postwrenchn, on Aug 09 2016 - 20:54, said:

WOW, did you just want to mess with our heads or is it just me....the kill number go from high to low now. So along with a PIA update now I have to retrain myself

 

 

Yeah, that's my bad. I didn't purposely change it... it was an artifact of modifying the new XVM config files. It was screwing with my brain as well. I figured it was just a part of the new WoT changes since I didn't remember making that one change to that one line in one of the 30+ config files a couple of years ago. ;-)

 

Changed now. Check out the new build going up now.



Bones #263 Posted Aug 11 2016 - 16:32

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Update 11 August:

 

Upgraded to XVM 6.4.1.1, build 6308 for WoT 0.9.15.1.1

 

This is the new stable build following the latest micropatch and includes some minor changes/fixes as well as the return of the multi-lined carousel.

 

Note: The minimap is still not operational. The XVM devs are still hard at work re-adding that functionality back into the mod.

 

 

Good tanking!



wrenchn #264 Posted Aug 24 2016 - 02:14

    First lieutenant

  • Players
  • 58622 battles
  • 818
  • Member since:
    05-25-2013
Nice update...working OK. Can't wait til you get an installer working ;)   Have trouble with the HTML stuff.

Bones #265 Posted Sep 15 2016 - 17:11

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 15 September:

 

Upgraded to XVM 6.4.3, build 6470 for WoT 0.9.15.2.

 

At the moment, the line of icons at the top of the screen in battle is broken - not sure where the problem is, but everything else seems to work. The XVM Devs have been hard at work at making the minimap functional again, but that is still not complete. As soon as I can make updates to the config files to fix any additional minor glitches, I'll post again.

 

Good tanking!

 



oochycoo #266 Posted Sep 25 2016 - 12:43

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

Hi Bones

 

I had a look through the posts but couldnt see if these requests had already come up - also not sure if what I am asking for isnt there because xvm minimap still has issues


 

But -

1. there used to be a line showing where your gun was pointing - I still get the two traverse lines but the gunline is missing and I couldnt see where in the configs to enable/disable it

2. A friend of mine who plays was talking about dead tanks (friend and foe) being shown on the map - im not convinced its a great idea but I would like to try it and see - is there a way to do that?

3. I use a third party damage announcer at present - is that something that xvm can do?


 

Thanks in advance for any time you spend answering - keep up the great work :)


Edited by oochycoo, Sep 25 2016 - 12:44.


Bones #267 Posted Sep 26 2016 - 02:01

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

View Postoochycoo, on Sep 25 2016 - 05:43, said:

 

1. there used to be a line showing where your gun was pointing - I still get the two traverse lines but the gunline is missing and I couldnt see where in the configs to enable/disable it

2. A friend of mine who plays was talking about dead tanks (friend and foe) being shown on the map - im not convinced its a great idea but I would like to try it and see - is there a way to do that?

3. I use a third party damage announcer at present - is that something that xvm can do?

 

NP...

 

1 - That's something WG screwed up. Sometime in the last couple of patches they broke the line.

2 - I believe there is. If you want to try that, you'll have to wait until XVM fully enables minimap functionality (which is coming, see below). Then, did in to minimapLabelsTemplates.xc and change the appropriate alpha values (and colors) to appropriate levels.

3 - Sorry, nope. I suspect that eventually it might, given the number of other third-party mods that have been incorporated into XVM, but at this point I haven't seen any indication that anyone is working on it.

 

Note - XVM seems to have finally gotten to a point where minimap functionality is once again available. I'm working right now on updating my config.


Edited by Bones, Sep 26 2016 - 02:35.


Bones #268 Posted Sep 26 2016 - 05:22

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 25 September:

 

Updated to XVM 6.4.5 build 6499.

 

This latest stable release brings back FULL minimap functionality!

 

I've updated a number of individual config files to work with newer release features in XVM, but there are still a few unresolved issues that frankly continue to stump me. Specifically, in battle there is a line of "null"s at the top center of the screen in battle below the team tank icons that *should* display the team HP pools. I'm still working on that (but if anyone has any Ideas on how to fix that, I'm all ears).

 

Good tanking!



Bones #269 Posted Oct 05 2016 - 16:25

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 5 OCTOBER:

 

Updated to XVM 6.4.6.1 build 6569 for WoT 0.9.16

 

The majority of the changes to this version include integration with WoT's new native multi-lined carousel, with some other minor changes as well.

 

Good tanking!

 



xWarHammer1992x #270 Posted Oct 06 2016 - 00:45

    Sergeant

  • -Players-
  • 2121 battles
  • 100
  • Member since:
    12-23-2015

Just a heads up: 

 

1) the current version of XVM interrupts the new Damage Panel and the battle progress/hitlog as well. I don't know why. 

 

2) For some odd reason the Tech Tree totally disappears. 



Bones #271 Posted Oct 06 2016 - 03:19

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

I was having some strange problems on initial install (in garage, I had trouble clicking on tanks as an example). I closed the game down, did a hard reboot, and after that I didn't have any problems.

 

I've been playing all day, and the only XVM problems I've encountered are that the minimap resets to its smallest size at the beginning of each game. I have seen no problems with the hitlog or received damage log (though I also use GambitER's damage log and had to move that to the right so as to not interfere with WoT's three line damage recevied/blocked/assisted panel).

 

Check other mods, especially ones you wouldn't normally expect. As another example, I use J1mb0's contour icons, but installing the version from 9.15.1/2 broke the icons in WoT's three-line info panel. 

 



Bones #272 Posted Oct 11 2016 - 18:21

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 11 OCTOBER:

 

Updated to XVM 6.4.6.2 build 6577.

 

This new build fixes the problem with the minimap automatically resetting to its smallest size at the beginning of each battle.

 

 

Good taking!



BaronVonRollup #273 Posted Oct 13 2016 - 13:48

    Private

  • -Players-
  • 61 battles
  • 1
  • Member since:
    06-08-2014

I admit that I'm a 61 year old self taught computer jockey (who has trouble riding a horse!) but I cannot get the bloody thing to work.

Its driving me mad because I believe its the best XVM version around. 

I used to download it with the Odem Mortis mod pack but its not working since the latest 'upgrade' (yes, right!) of the game.

Odem Mortis have no support available so I downloaded it from this page.

 I got seven bits and pieces which I transfered into my WOT's folder but its done diddly squat.... (((((((   HELP!!!    ;))))))).

My e mail is captg.damd@gmail.com which I use for all WOT's associated dubry ferkins and clan bits and bobs.

Any advice gratefully accepted (pretty please with a cherry on top!) but please don't mention "barbie" or "tetris" to me!

CaptG (Peter)


Edited by BaronVonRollup, Oct 13 2016 - 13:52.


nerd65 #274 Posted Dec 05 2016 - 09:12

    Corporal

  • Players
  • 38998 battles
  • 26
  • [DRT] DRT
  • Member since:
    04-22-2012
Are you not supporting this mod anymore?

Bones #275 Posted Dec 14 2016 - 21:39

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Update 14 December 2016:

 

Upgraded to XVM 6.5.0 build 6900 for WoT 0.9.17.

 

Not a lot has changed in the mod, save for the addition of the newest tanks added to the game (the Swedes as well as all of the new premium tanks released/to be released this month).

 

Good tanking!



nerd65 #276 Posted Dec 15 2016 - 10:12

    Corporal

  • Players
  • 38998 battles
  • 26
  • [DRT] DRT
  • Member since:
    04-22-2012
Thx Bones! wish this was in Aslains mod pack :(

Bones #277 Posted Dec 16 2016 - 18:03

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

Update 16 December:

 

Adjusted this config to work for WoT 0.9.17.0.1 (the Christmas micropatch).

 

Nothing has changed in XVM. The only thing apparently necessary was moving everything from the /res_mods/0.9.17.0/ directory into the /0.9.17.0.1/ directory (so no need to download if you don't want to - just copy|paste everything into the 0.9.17.0.1 directory).

 

Good tanking!



Dfektiv_77 #278 Posted Jan 05 2017 - 04:31

    Private

  • -Players-
  • 0 battles
  • 1
  • Member since:
    01-05-2017

Greetings from the SEA server.

I've been using your "no stats version" for a while now and have not noticed any issues until the other day when i gave it to a friend with a few changes back to WG's defaults. mainly camera and minimap.

His copy worked perfectly, including "damage taken log", which i've never seen working on mine.

As a test i ran his version on my laptop, but it still didn't show the "damage taken log".

 

I understand it's likely a problem with my laptop's proprietary software conflicting somehow and i don't expect you to rewrite your pack to fix it just for me, the software runs my cooling fans, sorry but i need them.

I was hoping you might be able to point me in the right direction with what i may be missing with changing a XVM version that shows the "damage taken log" on my laptop?

 

The SEA server is still on 0.9.17.0, compared to the rest who are on 0.9.17.0.1, but it doesn't seem to have made a difference to your mod working

The XVM build i have is 6.5.0.1 which gives me the "damage taken log".

 

Where i am having issues is making the players panel colour the names with tank types like your's does, i used your setup as a reference (np++ compare plugin is awesome for this) and made the changes, but it stays as default colour.

From what i can tell, i only need to change the macro from {{c:r}} to {{c:vtype}} in font colour as needed.

 

Extract from Playerspanel.

 // Display format for player nickname (macros allowed, see macros.txt).
      // Формат отображения имени игрока (допускаются макроподстановки, см. macros.txt).
      "nickFormatLeft": "<font color='{{c:r}}' alpha='{{alive?#FF|#80}}'>{{name%.12s~..}}</font> <font alpha='#A0'>{{clan}}</font>",

 

Am i missing something somewhere else?

Any other changes besides in "playerspanel.xc" seem to work

 

(Jan 05  '17) Don't worry, seems i was able to copy the required files from your version over the top without too many issues

Love your config by the way

 


Edited by Dfektiv_77, Jan 07 2017 - 08:00.


Bones #279 Posted Jan 24 2017 - 17:39

    Staff sergeant

  • Beta Testers
  • 37409 battles
  • 323
  • [CB] CB
  • Member since:
    08-05-2010

UPDATE 24 January:

 

Upgraded to XVM 0.5.4 built 7094 for WoT 0.9.17.0.3.

 

Looks like minor changes and updates to the mod itself. None of the config files have changed. 

 

Good tanking!



oochycoo #280 Posted Feb 06 2017 - 21:08

    Corporal

  • -Players-
  • 0 battles
  • 14
  • Member since:
    10-18-2012

in the last couple of days I have started seeing a tiny lightbulb with a line through it on my tank and usually on one other tank in the playerpanel

 

I hadnt noticed it before - does it mean anything?

 

should I turn it off?

 

Its just kinda annoying

 

 

Its there right at the countdown into battle so it cant be spotted or not spotted - and it appears usually on my tank and another tank of the same tier - not a platoon member or anything.


 

Any thoughts?


 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users