Jump to content


[0.9.5] ClanMod


  • Please log in to reply
81 replies to this topic

BONNe1704 #61 Posted Nov 08 2014 - 22:37

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012

In clanMod there are nothing like 'first_message'.

And I also use XVM 3404 but didnt find this message.

 

Also, clanMod paste all log fails to WOT / logs folder. So if there are errors from clanMod, they will be in clanMod.log file. Check it please.



Maggz #62 Posted Nov 08 2014 - 23:05

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

and here is the clanmod logs sorry missed this one.

 


>------------------------------------------<
02/11/2014 22:00 [clanMod] Mod started.
02/11/2014 22:00 [clanMod] Author: BONNe1704
02/11/2014 22:00 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
03/11/2014 18:13 [clanMod] Mod started.
03/11/2014 18:13 [clanMod] Author: BONNe1704
03/11/2014 18:13 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 01:26 [clanMod] Mod started.
04/11/2014 01:26 [clanMod] Author: BONNe1704
04/11/2014 01:26 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 01:30 [clanMod] Mod started.
04/11/2014 01:30 [clanMod] Author: BONNe1704
04/11/2014 01:30 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 01:33 [clanMod] Mod started.
04/11/2014 01:33 [clanMod] Author: BONNe1704
04/11/2014 01:33 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 18:28 [clanMod] Mod started.
04/11/2014 18:28 [clanMod] Author: BONNe1704
04/11/2014 18:28 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 19:06 [clanMod] Mod started.
04/11/2014 19:06 [clanMod] Author: BONNe1704
04/11/2014 19:06 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 21:52 [clanMod] Mod started.
04/11/2014 21:52 [clanMod] Author: BONNe1704
04/11/2014 21:52 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
04/11/2014 22:01 [clanMod] Mod started.
04/11/2014 22:01 [clanMod] Author: BONNe1704
04/11/2014 22:01 [clanMod] Version: 0.9.2.4
[EXCEPTION] (res_mods/0.9.2/scripts/client/mods/zClanMod.py, 449):Traceback (most recent call last):
  File "res_mods/0.9.2/scripts/client/mods/zClanMod.py", line 373, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting , delimiter: line 17 column 13 (char 490)

>------------------------------------------<
06/11/2014 18:21 [clanMod] Mod started.
06/11/2014 18:21 [clanMod] Author: BONNe1704
06/11/2014 18:21 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:14 [clanMod] Mod started.
08/11/2014 15:14 [clanMod] Author: BONNe1704
08/11/2014 15:14 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:19 [clanMod] Mod started.
08/11/2014 15:19 [clanMod] Author: BONNe1704
08/11/2014 15:19 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:21 [clanMod] Mod started.
08/11/2014 15:21 [clanMod] Author: BONNe1704
08/11/2014 15:21 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:22 [clanMod] Mod started.
08/11/2014 15:22 [clanMod] Author: BONNe1704
08/11/2014 15:22 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:24 [clanMod] Mod started.
08/11/2014 15:24 [clanMod] Author: BONNe1704
08/11/2014 15:24 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:26 [clanMod] Mod started.
08/11/2014 15:26 [clanMod] Author: BONNe1704
08/11/2014 15:26 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:36 [clanMod] Mod started.
08/11/2014 15:36 [clanMod] Author: BONNe1704
08/11/2014 15:36 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<
08/11/2014 15:38 [clanMod] Mod started.
08/11/2014 15:38 [clanMod] Author: BONNe1704
08/11/2014 15:38 [clanMod] Version: 0.9.4.6
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 460):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 384, in get_update
  File "scripts/common/Lib/json/__init__.py", line 278, in load
  File "scripts/common/Lib/json/__init__.py", line 326, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 384, in raw_decode
ValueError: No JSON object could be decoded

>------------------------------------------<

 

sorry for missing this part of your instructions bud



BONNe1704 #63 Posted Nov 09 2014 - 01:30

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012

Yes sorry :D

 

Epic my fail on updater. Now all must work. Nothing to mod, just forget to remove ',' in update notification. Sorry.



Maggz #64 Posted Nov 09 2014 - 01:37

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

so new upload coming?

 



BONNe1704 #65 Posted Nov 09 2014 - 01:51

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012

No, it must work now.

 

Fail was not in mod side, but in update server side.



Maggz #66 Posted Nov 09 2014 - 01:55

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011
gotcha sorry and ty bud

Maggz #67 Posted Nov 09 2014 - 04:32

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

ok a new set of errors, it will not process battles at the moment pressing f11 to force reload produces this result:

 

08/11/2014 20:46 [clanMod] Mod started.
08/11/2014 20:46 [clanMod] Author: BONNe1704
08/11/2014 20:46 [clanMod] Version: 0.9.4.6
08/11/2014 22:25 [clanMod] Mod started.
08/11/2014 22:25 [clanMod] Author: BONNe1704
08/11/2014 22:25 [clanMod] Version: 0.9.4.6

[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 811):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 738, in update_clan_wars
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.
[EXCEPTION] (res_mods/0.9.4/scripts/client/mods/zClanMod.py, 497):Traceback (most recent call last):
  File "res_mods/0.9.4/scripts/client/mods/zClanMod.py", line 473, in timer
TypeError: Write failed.

 

hopefully this helps you, i am seeing clan member count just not seeing any battles process.



BONNe1704 #68 Posted Nov 09 2014 - 14:32

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012

Please, can you tur no debug mode?

In the res_mods/configs/clanMod/ clanMod.cfg file

 

And when you get error, please upload log again.



Maggz #69 Posted Nov 09 2014 - 18:37

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011
will do that this evening again and repost for you.

Maggz #70 Posted Nov 10 2014 - 02:12

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

It looks to be working tonight, but here is the log file from latest login with debug on.

 

>------------------------------------------<
09/11/2014 20:08 [clanMod] Mod started.
09/11/2014 20:08 [clanMod] Author: BONNe1704
09/11/2014 20:08 [clanMod] Version: 0.9.4.6
09/11/2014 20:08 [UPDATE] {u'subversion': u'14', u'version': u'0.9.4.6', u'subchanges': {u'lv': [u'Atjaunota RO valoda'], u'ru': [u'\u041e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u043e RO \u044f\u0437\u044b\u043a.'], u'en': [u'Updated RO languages.']}, u'changelog': {u'lv': [u'Atjaunin\u0101ts uz versiju 0.9.4'], u'ru': [u'\u041e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0434\u043e \u0432\u0435\u0440\u0441\u0438\u0438 0.9.4.'], u'en': [u'Updated to version 0.9.4']}}
09/11/2014 20:08 [SERVER] {'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'server': 'com'}
09/11/2014 20:08 [ClanMod] {'lang': 'en', 'map': 1, 'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'clanID': 0, 'server': 'com'}
09/11/2014 20:08 [SERVER] {'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'server': 'com'}
09/11/2014 20:08 [ClanMod] {'lang': 'en', 'map': 1, 'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'clanID': 1000015601, 'server': 'com'}
09/11/2014 20:08 [TIMER] Prev 2014-11-10 00:52:00
09/11/2014 20:08 [TIMER] Now 2014-11-10 01:08:28.898000
09/11/2014 20:08 [DOWNLOAD] {u'status': u'ok', u'count': 1, u'data': {u'1000015601': [{u'provinces_i18n': [{u'name_i18n': u'Cape Farewell', u'province_id': u'GL_26'}], u'provinces': [u'GL_26'], u'started': True, u'private': None, u'time': 1415583543, u'arenas': [{u'name_i18n': u"Fisherman's Bay", u'name': u'36_fishing_bay', u'arena_id': u'36_fishing_bay'}], u'type': u'landing'}]}}
09/11/2014 20:08 [DOWNLOAD] {u'status': u'ok', u'count': 1, u'data': {u'GL_26': {u'clan_id': 1000003159}}}
09/11/2014 20:08 [DOWNLOAD] {u'status': u'ok', u'count': 1, u'data': {u'1000003159': {u'abbreviation': u'ACC', u'emblems': {u'large': u'http://clans.worldof...blem_64x64.png', u'small': u'http://clans.worldof...blem_24x24.png', u'bw_tank': u'http://clans.worldof...64x64_tank.png', u'medium': u'http://clans.worldof...lem_32x32.png'}, u'name': u'Armored Cross Cavaliers', u'clan_color': u'#FFFFFF'}}}
09/11/2014 20:08 [TIMER] Prev 2014-11-10 01:08:00
09/11/2014 20:08 [TIMER] Now 2014-11-10 01:08:30.896000
09/11/2014 20:08 [TIMER] Prev 2014-11-10 01:08:00
09/11/2014 20:08 [TIMER] Now 2014-11-10 01:08:34.261000
09/11/2014 20:08 [TIMER] Prev 2014-11-10 01:08:00
09/11/2014 20:08 [TIMER] Now 2014-11-10 01:08:37.203000

>------------------------------------------<

 

seems to be working ok now, dunno why yesterday it wasn't tho.



Maggz #71 Posted Nov 20 2014 - 22:50

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

ok after the micropatch with only this mod installed there seems to be a minor issue, it does not stop the mod from functioning. it only posts an error to the python log.

the error is:

 

[ERROR] (scripts/client/notification/NotificationListView.py, 31): Invalid state of the Notifications Model

 

turning the debug mode to true gives me this in the clanmod log:

 

20/11/2014 16:45 [clanMod] Mod started.
20/11/2014 16:45 [clanMod] Author: BONNe1704
20/11/2014 16:45 [clanMod] Version: 0.9.4.6
20/11/2014 16:45 [UPDATE] {u'subversion': u'14', u'version': u'0.9.4.6', u'subchanges': {u'lv': [u'Atjaunota RO valoda'], u'ru': [u'\u041e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u043e RO \u044f\u0437\u044b\u043a.'], u'en': [u'Updated RO languages.']}, u'changelog': {u'lv': [u'Atjaunin\u0101ts uz versiju 0.9.4'], u'ru': [u'\u041e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0434\u043e \u0432\u0435\u0440\u0441\u0438\u0438 0.9.4.'], u'en': [u'Updated to version 0.9.4']}}
20/11/2014 16:45 [SERVER] {'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'server': 'com'}
20/11/2014 16:45 [ClanMod] {'lang': 'en', 'map': 1, 'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'clanID': 0, 'server': 'com'}
20/11/2014 16:46 [SERVER] {'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'server': 'com'}
20/11/2014 16:46 [ClanMod] {'lang': 'en', 'map': 1, 'api': '2ebc4561ec55d12e7efd2bcb355bcb13', 'clanID': 1000010188, 'server': 'com'}
20/11/2014 16:46 [TIMER] Prev 2014-11-20 21:37:00
20/11/2014 16:46 [TIMER] Now 2014-11-20 21:46:26.443000
20/11/2014 16:46 [TIMER] Prev 2014-11-20 21:37:00
20/11/2014 16:46 [TIMER] Now 2014-11-20 21:46:30.294000
20/11/2014 16:46 [TIMER] Prev 2014-11-20 21:37:00
20/11/2014 16:46 [TIMER] Now 2014-11-20 21:46:33.311000

 

As stated this isn't breaking the mod it just seems to post this error every time I press the notification window opening tab in game. I hope this helps in resolving this minor issue. Aside from that man great mod works great and I do love it. Ty for your hard work on it.



Gamisou #72 Posted Nov 30 2014 - 04:03

    Sergeant

  • Players
  • 14249 battles
  • 127
  • Member since:
    10-27-2013
Yeah when I press the button ClanWars if it even shows up it goes away and nothing. Seems it just started after micro patch.

Gamisou #73 Posted Dec 02 2014 - 00:18

    Sergeant

  • Players
  • 14249 battles
  • 127
  • Member since:
    10-27-2013
OK, I figured it out. If you are using the latest XVM (nightly) and over right the res_mod files with this whole archive it does not work correctly as stated above. If you ins tall fresh XVM then just copy the zClanMod.pyc file and the whole "config" folder it works fine. Must have been over righting some of the newer files for example CameraNode.pyc.

BigNaturals #74 Posted Jan 03 2015 - 22:40

    Major

  • Beta Testers
  • 55506 battles
  • 2,514
  • [MAHOU] MAHOU
  • Member since:
    10-03-2011
are you updating this to 9.5?  If not do you mind sharing the info and we will try and continue updating this mod with credits to you and who ever else.

BONNe1704 #75 Posted Jan 07 2015 - 17:45

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012
Mod works on 9.5. Just it is in 0.9.4 folder. Will update folder ASAP

Maggz #76 Posted Jan 12 2015 - 05:57

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011
Bonne, this does not work currently. atleast not fully. The reason being is WG changed the API recently. in the provinces file there is no longer a timestamp for the prime_time label. instead there is now only a timezone code for instance on NA server East coast timezone of 8pm. the time code for prime_time now comes out as 1. WG has changed this across not only the NA API but also the EU API. I am sure with that information that you could be able to come to some sort of workaround for this. Note this only affects battles time which have not seeded. So if a battle has seeded or has a timestamp, it does properly obtain that data.

Maggz #77 Posted Jan 13 2015 - 06:39

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011
OK I got tired of waiting so I rewrote this to work under the current API. I do not want to wait till the end of a patch just to make a mod function properly. GL with this Bonne, you have done great work on this and I was glad you had done this to this point. If you are looking to view my remastered version of this PM me and I will send you a link. I do not really post my mods on WG forums anymore. GL man.

eLMariachi_OD #78 Posted Jan 14 2015 - 09:29

    Private

  • -Players-
  • 0 battles
  • 1
  • Member since:
    01-14-2015
Should I wait for an update?:B


BONNe1704 #79 Posted Jan 14 2015 - 10:17

    Corporal

  • Players
  • 0 battles
  • 29
  • Member since:
    05-31-2012

View PostMaggz, on Jan 12 2015 - 06:57, said:

Bonne, this does not work currently. atleast not fully. The reason being is WG changed the API recently. in the provinces file there is no longer a timestamp for the prime_time label. instead there is now only a timezone code for instance on NA server East coast timezone of 8pm. the time code for prime_time now comes out as 1. WG has changed this across not only the NA API but also the EU API. I am sure with that information that you could be able to come to some sort of workaround for this. Note this only affects battles time which have not seeded. So if a battle has seeded or has a timestamp, it does properly obtain that data.

 

Hmm... prime_time was never a TimeStamp object. It always was a integer from 0 - 23. It represents hour (GMT +0)  when zone is closing. So for NA mostly it is 23-4, for EU 15-20. And it is not changed recently, it is like that from start, and I never work with it as a TimeStamp object. So I do not know what you change... but defiantly, there was no problem.

 

 

But I did not found problem with battletime. Check eu and na apis and clans web page and both give the same time.

 

And I update mod: Download there

 



Maggz #80 Posted Jan 14 2015 - 21:14

    Captain

  • Players
  • 39081 battles
  • 1,041
  • Member since:
    12-02-2011

this is the error it was creating for non seeded battles(battles with an approximate battle time):

 

ValueError: year=1899 is before 1900; the datetime strftime() methods require year >= 1900

 

if you are saying you did not find any errors in your mod, that has been happening on numerous occasions to not only me, but numerous others. looking at your mods internals it was apparent you were trying to get a timestamp and not a timezone code to process from. I really cant go into it further about it as posting needless code bits here would not help anyone. I am glad you now have your mod working (tho ive not tested it). Good luck in the future with your project.






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users