Jump to content


Prem account not working


  • This topic is locked This topic is locked
4 replies to this topic

Kagedtanker #1 Posted Jul 25 2011 - 21:45

    Private

  • Players
  • 12924 battles
  • 3
  • Member since:
    07-01-2011
I just activated a prem account but I do not seem to be getting the 50% bonus to credits and exp. I have seen no increase compared to normal games. I restarted the game but that didnt work.

tankboy1138 #2 Posted Jul 25 2011 - 21:49

    Captain

  • Players
  • 13188 battles
  • 1,488
  • [TB] TB
  • Member since:
    02-23-2011
It's kinda hard to notice at times... but you WILL notice it. it's in effect, but the primary benefit of premium is over a long period of time. over the span of a dozen battles, you won't notice the effects much. Over the span of 100+, you WILL start to notice it.

ZKaiZ #3 Posted Jul 25 2011 - 21:51

    Major

  • Players
  • 17282 battles
  • 2,043
  • Member since:
    01-31-2011
Played on a friend's Jagd Panzer IV without premium = 700 exp.

Played on another friend's Jagd Panzer IV with premium = 1.5k exp.

Oh its there alright.

SFR_Orion126 #4 Posted Jul 25 2011 - 21:58

    Sergeant

  • Beta Testers
  • 11590 battles
  • 186
  • Member since:
    10-28-2010
Just curious but on the top right of your garage does it say "Standard" or "Premium"?

Kagedtanker #5 Posted Jul 25 2011 - 22:04

    Private

  • Players
  • 12924 battles
  • 3
  • Member since:
    07-01-2011
It says premium, maybe I'm just not seeing it. Not very good still.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users