Jump to content


AMD RX480 Driver Crash


  • Please log in to reply
89 replies to this topic

KnightOfEris #81 Posted Mar 23 2017 - 17:07

    Staff sergeant

  • -Players-
  • 6181 battles
  • 269
  • Member since:
    12-20-2014

Setting foliage to low will fix the problem, DX9 won't make a difference, no need to switch.



Pax256 #82 Posted Mar 23 2017 - 17:09

    Corporal

  • Players
  • 15133 battles
  • 52
  • Member since:
    07-23-2013

I put foliage on medium and so far ok... but it lasted a long time on high as well before hard lock. Also had crashes with foliage on low on dx11 which is why started to play around with shadows as well.

 

Hope the next update fixes this. I dont gain fps dropping foliage or shadows. And dont need to.

 


Edited by Pax256, Mar 23 2017 - 17:11.


LpBronco #83 Posted Mar 23 2017 - 21:17

    Major

  • Beta Testers
  • 36804 battles
  • 2,042
  • [_F_] _F_
  • Member since:
    11-19-2010
I may have found something. I had view range markers on map enabled in game and with the mods and somewhere along the line during this ordeal had lost in game crew announcements. I disabled the in game map circles and the crew voices returned. So there was a conflict with something somewhere. I'll run as is for a while and maybe remove the mods map circles for the stock ones when I update again.

deorum #84 Posted Jul 10 2017 - 19:57

    Corporal

  • Beta Testers
  • 0 battles
  • 14
  • Member since:
    10-27-2010

Please count me in also if you find solution to the problem, because this is so frustrating. 
Foliage/shadows lower settings doesnt seem to work for me. Still crashes 

 

First time also, today it crashed while in garage. 


I think it has to do with Global Wattman. I tried overvoltage & lower Freq, (although my card has passed all stress tests, and i play other games ok), it seems to help, but i am not sure yet.

 

I have tried various drivers, and i have the latest now. 

 

I am now playing full screen (all crashes happened while windowed), all settings maxed-out, with a little overvoltage, and somehow lower freq, it seems stable. I will let you know. 
Its the only game so far that has problems with my GPU (GB RX480 8gb). 

edit- it crashed on garage, in Fullscreen also. so that doesnt work either. it was also over-voltted.


Edited by deorum, Jul 10 2017 - 22:29.


Pax256 #85 Posted Jul 11 2017 - 03:35

    Corporal

  • Players
  • 15133 battles
  • 52
  • Member since:
    07-23-2013

View Postdeorum, on Jul 10 2017 - 19:57, said:

Please count me in also if you find solution to the problem, because this is so frustrating. 
Foliage/shadows lower settings doesnt seem to work for me. Still crashes 

 

First time also, today it crashed while in garage. 


I think it has to do with Global Wattman. I tried overvoltage & lower Freq, (although my card has passed all stress tests, and i play other games ok), it seems to help, but i am not sure yet.

 

I have tried various drivers, and i have the latest now. 

 

I am now playing full screen (all crashes happened while windowed), all settings maxed-out, with a little overvoltage, and somehow lower freq, it seems stable. I will let you know. 
Its the only game so far that has problems with my GPU (GB RX480 8gb). 

edit- it crashed on garage, in Fullscreen also. so that doesnt work either. it was also over-voltted.

 

My crash prob went away couple months ago. Especially sacred valley and arctic circle... No idea what fixed it. Micro update from WG or some driver update that kicked in. Now on 17.6.1 and fine. Your prob maybe related to ocing. Dont bother ocing you dont get much more perf out of it. At least dont go over 1400 core and dont touch the ram. Also GB didnt have the best cooler. XFX does tho the RX580 series have much better coolers now all around.

deorum #86 Posted Jul 11 2017 - 20:33

    Corporal

  • Beta Testers
  • 0 battles
  • 14
  • Member since:
    10-27-2010

I dont have OC, anywhere!

On the contrary i have Downclocked (overvoltage usually results on more stable systems on the price of temperature increase). Overvoltage is not overclocking.

And i did that because on default settings... i crashed. 
BTW i believe all new cards, apply an default OC overclocking, based on load. 

update to my (our) problem : I crashed again, even with no OC and lower GPU freqs... Althought it seems more stable (instead of continuus crashes, i got just one). 
 


Edited by deorum, Jul 11 2017 - 21:00.


Pax256 #87 Posted Jul 12 2017 - 05:03

    Corporal

  • Players
  • 15133 battles
  • 52
  • Member since:
    07-23-2013

View Postdeorum, on Jul 11 2017 - 20:33, said:

I dont have OC, anywhere!

On the contrary i have Downclocked (overvoltage usually results on more stable systems on the price of temperature increase). Overvoltage is not overclocking.

And i did that because on default settings... i crashed. 
BTW i believe all new cards, apply an default OC overclocking, based on load. 

update to my (our) problem : I crashed again, even with no OC and lower GPU freqs... Althought it seems more stable (instead of continuus crashes, i got just one). 
 

 

Id reset things back to standard settings and see. If you think temps might be an issue set 85c down from 90c and unlock the fan curve. Mind you I ended up setting max fan speed at 2500 rpm so the gpu throttled maybe 1% of the time from 1338 mhz. I could run 1400 but needed strong fan curve to keep temps lower than 85c that I thought 90c was too high a max. But again all my tinkering in wattman never solved my crash issues. I dont know what did but it just went away completely suddenly ~3 months ago. WOT was the only game that was crashing for me. All other games were solid. 

 

Try diff drivers?



ZeuS1911 #88 Posted Jul 12 2017 - 06:26

    Staff sergeant

  • Players
  • 25201 battles
  • 290
  • [4NZAB] 4NZAB
  • Member since:
    12-29-2011

I've got some advice, you might not like it though.

 

Use DDU (display driver uninstaller) to fully uninstall the video drivers, reinstall and don't install 'Relive' at all.

 

Disable High Definition Audio Device (the one for the video card) in the 'Device manager', under Sound, video and game controllers.  Maybe more then one if you have crossfire.

 

Don't use wattman, just overclock with the built in overclocking tool in the AMD drivers. Anything with overlay seems to cause crashes, this includes VLC unless you've disabled a bunch of stuff in it.

 

Add -clientGraphicsAPI d3d9 to your games shortcut target path.

 

Right click on shortcut for WoT, properties.  Find target and make it look something like below:

 

C:\World_of_Tanks\WoTLauncher.exe -clientGraphicsAPI d3d9

 

You may need to go to low foilage also.



RogueNinjaxixigames #89 Posted Jul 12 2017 - 23:40

    Sergeant

  • -Players-
  • 20563 battles
  • 109
  • [SOAPS] SOAPS
  • Member since:
    12-12-2015

View PostSuperShermanTanker2, on Jul 17 2016 - 22:36, said:

So ever since I got my new AMD RX480 GPU the driver has been crashing when I play world of tanks I do play using some mods but those mods work fine when I use my old GPU I'm kinda confused now on what to do because I don't know if it could be causing the driver crash and I have reinstalled the latest driver multiple times the driver crash happens randomly and only when I'm playing world of tanks

 

want a tip? download the original driver from the CDand DONT update it -_-

AMD has good graphic but pos drivers so try not to [edited]with them


Edited by RogueNinjaxixigames, Jul 12 2017 - 23:43.


Pax256 #90 Posted Jul 12 2017 - 23:55

    Corporal

  • Players
  • 15133 battles
  • 52
  • Member since:
    07-23-2013
Ya 16.11.5 worked fine for me as well before the fix happened. Id go back to it until the newest driver or WOT update deals with it...




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users