Jump to content


Are the servers broken?


  • Please log in to reply
8 replies to this topic

obsidion #1 Posted Sep 10 2016 - 09:51

    Sergeant

  • Players
  • 9271 battles
  • 122
  • Member since:
    09-25-2011

Just wondering if the servers are broken?

 

I have been lagging like crazy lately and my ping keeps going up to and past 600, my tank turns in random directions, my reticle is never lined up with the gun. It's just not good at all. It's not my connection as the game has never been like this before, servers broken or just me?



thejoker91 #2 Posted Sep 10 2016 - 09:53

    Major

  • Beta Testers
  • 18738 battles
  • 6,288
  • [E-50M] E-50M
  • Member since:
    09-23-2010

Probably telia being crapagain. The hamsters that power the servers probably got tired or something.



DeutschesKaiserreich #3 Posted Sep 10 2016 - 11:29

    Major

  • Players
  • 23802 battles
  • 14,310
  • Member since:
    03-18-2013
Get a better ISP. Dial up is outdated.

Captapple2725 #4 Posted Sep 10 2016 - 12:04

    Private

  • -Players-
  • 8251 battles
  • 4
  • [TANKX] TANKX
  • Member since:
    12-01-2015
had issues last night also..logged out and back in better..

mp31b30q9 #5 Posted Sep 10 2016 - 12:04

    Major

  • Players
  • 46753 battles
  • 10,160
  • [SHIMP] SHIMP
  • Member since:
    09-02-2011
Google "WoT Ping Lottery"

Gomez_Adams #6 Posted Sep 10 2016 - 12:08

    Major

  • -Players-
  • 5 battles
  • 5,402
  • Member since:
    04-06-2015

Wargaming North America is the absolute worst game on earth for packet loss. It has been for 5 years running.



obsidion #7 Posted Sep 10 2016 - 12:20

    Sergeant

  • Players
  • 9271 battles
  • 122
  • Member since:
    09-25-2011

View PostLaceylace, on Sep 10 2016 - 20:29, said:

Get a better ISP. Dial up is outdated.

Considering i'm with what claims to be "The best Internet Provider" and currently have the bes internet package i can get I don't see how changing will do anyhting 

 

View PostGomez_Adams, on Sep 10 2016 - 21:08, said:

Wargaming North America is the absolute worst game on earth for packet loss. It has been for 5 years running.

 

Happens on the SEA server as well 



mp31b30q9 #8 Posted Sep 10 2016 - 13:14

    Major

  • Players
  • 46753 battles
  • 10,160
  • [SHIMP] SHIMP
  • Member since:
    09-02-2011

View Postobsidion, on Sep 10 2016 - 06:20, said:

Considering i'm with what claims to be "The best Internet Provider" and currently have the bes internet package i can get I don't see how changing will do anyhting

 

You have to understand that some people's existence on this forum (and probably IRL too) is to refute the irrefutable.

zed2204 #9 Posted Sep 10 2016 - 13:16

    Major

  • -Players-
  • 37827 battles
  • 2,073
  • [LIO] LIO
  • Member since:
    11-09-2014
Yea unusual lag, ping is OK but lags in a certain part of the day for 5-6 days now
Idk what is is in US time, after 20.00 east EU time
The rest of the day is OK but
I had to stop playing last 3 days




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users