Jump to content


Tutorial: Setting Higher Performance for Nvidia Graphics Cards In World of Tanks


This topic has been archived. This means that you cannot reply to this topic.
56 replies to this topic

Cpt_Kill_Jack #1 Posted Aug 06 2011 - 17:14

    First lieutenant

  • Veteran Testers
  • 12369 battles
  • 699
  • [404] 404
  • Member since:
    07-14-2010
How to set Nvidia Graphics Card (GPU) to higher performance In WoT & WoWP:
By Cpt_Kill_Jack



This mostly helps high end graphics card and mid range graphics cards. Would also recommend another program like MSI Afterburner to set a custom fan profile but this is up to you.

- This option will not work for integrated mobile graphics cards.
- If you have ever rolled your drivers back or the option is not available this could be the reason why its not there. My suggestion is a clean driver install which I explain how to do with the the current driver 256 series and above in the driver installation section.
- XP drivers may not have the Power management options that Window Vista and 7 have.




Step one:
Open the Nvidia Control Panel.

Posted Image
Following steps will be taken from this image.

Step Two:
Click on Manage 3D settings.

Step Three:
Click on the Program Settings tab.
Note this is an important step because if you leave it set to global settings your gpu will never idle even in windows desktop.

Step Four:
If you do not see World of Tanks in the drop down list in the Program Settings menu please add the WorldOfTanks.exe (WorldofWarplanes.exe for WoWP) to the list from the root folder for world of tanks (World of Warplanes). If doing this for World of Warplanes please just substitute the locations for those that run WoWP.

Step Five:
Once you have World of Tanks or World of Warplanes selected in the drop down menu look for the Power management mode option and set it to Prefer maximum performance.

Step Six:
Apply the settings and start or restart your game.


Please note that if you update your drivers you will have to reapply these settings.


But these settings will make your graphics care in World of Tanks Stay at 100% usage meaning your getting the full power and not just what the driver thinks you need because the game doesn't load it enough. This should fix low FPS for The game. If you need anything explained any more in depth please let me know what needs further explanation and I would be happy to edit it.



My one other recommendation if you have a dedicated GPU and not an integrated one is that in the Graphics settings in game that you set texture compression to OFF. This makes the game render the textures and store them for use on your GPUs memory instead of your systems memory. This can help is your at all experiencing the Game crash or low resources warning for the game. The change uses about 500-600MB of GPU memory.






Driver Recommendations:

I recommend a clean driver install with 314.22 WHQL.  The link for the driver can be found at the bottom of the tutorial.
Please note that the Windows Vista and Windows 7 drivers are now also the drivers you download for Windows 8.


GeForce 314.22 WHQL for desktop GPUs: [Windows 8/Windows 7/Vista, 32-bit] [Windows 8/Windows 7/Vista, 64-bit]

GeForce 314.22 WHQL for desktop GPUs: [Windows XP, 32-bit] [Windows XP, 64-bit]
Spoiler                     


Verde 314.22 WHQL for notebook GPUs:  [Windows 8/Windows 7/Vista, 32-bit] [Windows 8/Windows 7/Vista, 64-bit]  
Important Information in Spoiler for Notebook GPUs
Spoiler                     


If have a request for a specific driver that is not listed here please just ask and I and get you a link.



Installing Drivers:
When installing drivers I would suggest going to the Custom section instead of standard and checking the box at the bottom that says Clean install.

This will remove your current driver and ask you to restart. Upon restart the driver install will begin and when its finished it will ask you once more to restart. After this your driver is installed and you shouldn't have any issues.

--------------------
Updates:


August 9th, 2011 - Updated possible reasons for option not to be available. Fix suggested is Clean driver install.
August 9th, 2011 -  Added Sections Updates, Driver Recommendations, and Installing Drivers.
February 14th, 2012 - Updated Drivers list, Driver Recommendation.
February 26th, 2012 - Updated Driver list for WHQL release of 295.73 drivers, Driver Recommendation Updated.
March 16th, 2012 - Updated Driver list for WHQL release of 296.10 drivers. Driver Recommendation Updated.
March 28th, 2012 - Updated Driver list for GTX680 release for its exclusive 301.10 WHQL drivers.
April 3rd, 2012 - Updated Driver list for release of Windows 8 Customer Preview Certified drivers. *Note that this driver only works on Windows 8*
May 2nd, 2012 - Fixed text size issue.
May 29th, 2012 - Updated Driver list for WHQL release of the 301.42 Drivers. Also removed the GTX680 section as the 600 series is now supported by these drivers.
June 6th, 2012 - Added Warning for updating to 301.42 driver if you have a factory overclocked card or a card with a Non-Reference PCB.
Sept 17th, 2012 - Updated drivers for release of 306.23 WHQL drivers. Removed the Windows 8 drivers section as they have been rolled into the Windows 7 and vista drivers. Updated supported GPU lists for new GPUs.
Dec 1st, 2012 - Updated driver links for windows 8, 7, Vista for 306.97 WHQL driver. Updated Driver links for Windows XP for 306.81 WHQL driver.
Feb 25th, 2013 - Updated Driver links for 314.07 WHQL Driver.
Mar 29th, 2013 - Updated Driver links for 314.22 WHQL Driver.

Trouble_SR #2 Posted Aug 06 2011 - 18:45

    First lieutenant

  • Players
  • 21490 battles
  • 697
  • [-NA-] -NA-
  • Member since:
    04-10-2011
I have a 9600GT and it does not have this option. Maybe with newer models only.

Cpt_Kill_Jack #3 Posted Aug 06 2011 - 19:03

    First lieutenant

  • Veteran Testers
  • 12369 battles
  • 699
  • [404] 404
  • Member since:
    07-14-2010
I would like to have some feedback from people that have used this or have tried to use this. Im trying to figure out why it works for some but not others so that I can better build the guide to help anyone with an Nvidia graphics card. I dont work with AMD cards much witch is why I dont have a tutorial up for those using AMD for better performance.

Please post your feedback.

gsus #4 Posted Aug 09 2011 - 06:38

    Private

  • Players
  • 5494 battles
  • 6
  • Member since:
    06-16-2011
Tried to use this method with a GeForce gtx 460 in Windows XP.

There is no Power Management mode option available with the most recent driver release.

NoblePlatoon #5 Posted Aug 09 2011 - 15:34

    Captain

  • Players
  • 15040 battles
  • 1,936
  • Member since:
    05-24-2011

View Postgsus, on Aug 09 2011 - 06:38, said:

There is no Power Management mode option available with the most recent driver release.
I confirm this statement.

Cpt_Kill_Jack #6 Posted Aug 09 2011 - 16:32

    First lieutenant

  • Veteran Testers
  • 12369 battles
  • 699
  • [404] 404
  • Member since:
    07-14-2010
I recommend a clean driver install with 266.58.  The link for the driver can be found at the bottom of the tutorial. The drivers 270 and above suffer from bugs and issues that come from Nvidia readying the drivers for Cuda 4.0 but Cuda 4.0 is not finished yet so these bugs are side effects of it not being included.


The 266.58 driver supports the following Graphics cards.
Spoiler                     


For the GTX 560Ti I suggest the 266.66 drivers. Which can be found here: http://www.nvidia.co...hql-driver.html



-------

A new driver 280.26 WHQL came out today but there is not enough feedback as of yet for me to know if it still has the issues I listed above or if they have been fixed. But you may download the driver here:  http://www.nvidia.co...hql-driver.html

Wolfrum #7 Posted Aug 09 2011 - 17:32

    Captain

  • Players
  • 16124 battles
  • 1,074
  • Member since:
    05-01-2011

View Postgsus, on Aug 09 2011 - 06:38, said:

Tried to use this method with a GeForce gtx 460 in Windows XP.

There is no Power Management mode option available with the most recent driver release.

That might be due to XP not having the same power management as Vista/7.

Thanks for the update,

The beta release before this new set 280 series did make some small improvments so lets see how these ones do with my SLI profiles tonight,

Wolf

Keats #8 Posted Aug 10 2011 - 20:30

    Staff sergeant

  • Beta Testers
  • 18965 battles
  • 256
  • Member since:
    09-01-2010
Is there anyway to turn off the smoke? I'm around 30fps normally, except when there's smoke in my view, I drop to ~1fps. It's better for enemies to miss me and shoot the ground in front of me, because I'll be unable to do anything for a few seconds. I really hate the smoke..

Ceptyr #9 Posted Aug 10 2011 - 21:23

    Sergeant

  • Beta Testers
  • 12018 battles
  • 187
  • [THUGZ] THUGZ
  • Member since:
    12-29-2010

View PostKeats, on Aug 10 2011 - 20:30, said:

Is there anyway to turn off the smoke? I'm around 30fps normally, except when there's smoke in my view, I drop to ~1fps. It's better for enemies to miss me and shoot the ground in front of me, because I'll be unable to do anything for a few seconds. I really hate the smoke..
These should help you:
Remove Smoke Effects (and more)
Minoson's Compressed Textures Pack (and more)

Wolfrum #10 Posted Aug 15 2011 - 17:14

    Captain

  • Players
  • 16124 battles
  • 1,074
  • Member since:
    05-01-2011
nVidia WHQL 280.XX Driver update:

So far I have seen a slight FPS boost when zoomed in sniping with my tanks, a lot of maps that had low FPS while idling for the countdown to happen have all but vanished for me.
Looks like the Driver set is stable thus Far, all 4 computers with different generations of Cards have not had an issue yet. SLI profiling works as well (my 460's) without fail and both cards spool up perfectly when playing.

So for those with mid-high end nVidia cards it looks like these drivers are a good set without faults (at least in WoT). Did over 200 games with them now.

-Wolf

Tabarnak #11 Posted Aug 15 2011 - 18:44

    Sergeant

  • Players
  • 4706 battles
  • 101
  • Member since:
    03-18-2011
Does adjusting the power setting to 100% increase the risk of the card overheating?

Or in other words: Will I have a potential cooling problem once I try this trick?

Cpt_Kill_Jack #12 Posted Aug 15 2011 - 19:11

    First lieutenant

  • Veteran Testers
  • 12369 battles
  • 699
  • [404] 404
  • Member since:
    07-14-2010
What video card do you have and no it probably wont overheat but depending on the temperature of your house and what not I personally like to have an aggressive fan profile in place because Nvidias is rather stupid to be honest.

Wolfrum #13 Posted Aug 15 2011 - 19:26

    Captain

  • Players
  • 16124 battles
  • 1,074
  • Member since:
    05-01-2011

View PostTabarnak, on Aug 15 2011 - 18:44, said:

Does adjusting the power setting to 100% increase the risk of the card overheating?

Or in other words: Will I have a potential cooling problem once I try this trick?


You can use programs like EVGA's Precision or MSI's AFterburner to manually control your Fan or make your own Fan profiles just to be sure.
That being said the BIOS hard coding for the fan profiles will usually prevent overheating granted that your Ambient Temperature is good, and you provide adequate airflow in the case. As well as making sure the card isn't chock full of Dust.
Those programs as well will let you know your operating temperature as well,

-Wolf

Royal_Pain #14 Posted Aug 17 2011 - 06:52

    First lieutenant

  • Players
  • 8043 battles
  • 892
  • Member since:
    04-03-2011
Its says like it was moved and to try again when i find the file and try to add it

INTREPID_5th #15 Posted Aug 18 2011 - 05:57

    Corporal

  • Players
  • 997 battles
  • 13
  • Member since:
    03-27-2011
The  280.26 WHQL Nvidia driver dropped my Tanks FPS on WinXP substantially.  I downgraded to 266.58 and everything is back to normal now.

You can use Nvidia Drivers up to and including 266.58 <<-- OK for Tanks
Driver:  266.58 from Nvidia Driver Archive:
http://www.nvidia.co...aspx?lang=en-us

Cpt_Kill_Jack #16 Posted Aug 19 2011 - 14:14

    First lieutenant

  • Veteran Testers
  • 12369 battles
  • 699
  • [404] 404
  • Member since:
    07-14-2010
Driver recommendations are listed near the end of the tutorial.

The 266.58 drivers are one of those it just works well drivers that you never want to stop using. This is the second time that I have done something like this and the first was like 197.41 which I was then forced to get something newer because I had newer cards.

Troupa #17 Posted Aug 19 2011 - 14:36

    Staff sergeant

  • Players
  • 16225 battles
  • 375
  • Member since:
    04-16-2011
Hey, thanks a lot.  I was using a 220gt and my frames went from 20-25 to about 30-35 :D

Wolfrum #18 Posted Aug 19 2011 - 16:45

    Captain

  • Players
  • 16124 battles
  • 1,074
  • Member since:
    05-01-2011

View PostINTREPID_5th, on Aug 18 2011 - 05:57, said:

The  280.26 WHQL Nvidia driver dropped my Tanks FPS on WinXP substantially.  I downgraded to 266.58 and everything is back to normal now.

You can use Nvidia Drivers up to and including 266.58 <<-- OK for Tanks
Driver:  266.58 from Nvidia Driver Archive:
http://www.nvidia.co...aspx?lang=en-us

I had a completely different experience, what cards are you running?

-Wolf

INTREPID_5th #19 Posted Aug 19 2011 - 17:26

    Corporal

  • Players
  • 997 battles
  • 13
  • Member since:
    03-27-2011
GTX 285

View PostWolfrum, on Aug 19 2011 - 16:45, said:

I had a completely different experience, what cards are you running?

-Wolf


Wolfrum #20 Posted Aug 19 2011 - 17:33

    Captain

  • Players
  • 16124 battles
  • 1,074
  • Member since:
    05-01-2011

View PostINTREPID_5th, on Aug 19 2011 - 17:26, said:

GTX 285

That might be why, you are 2 generations removed so the architecture isn't as optimzed.

I got both 460's, 470 and my 580. They all experienced a performance gain upon the 280.XX series of drivers. So for you it might make sense to roll them back, which is why I asked.

*edit/update* - I just plugged in a GTX275 Co-op Card, and using the 280's gave me a net loss in FPS performance with the same settings.



-Wolf