Jump to content


Investigating Reports of Lag


  • This topic is locked This topic is locked
261 replies to this topic

enjineer #261 Posted Apr 13 2017 - 19:37

    Major

  • Beta Testers
  • 46164 battles
  • 2,830
  • [-CMF-] -CMF-
  • Member since:
    12-07-2010

View PostDoomslinger, on Apr 13 2017 - 12:56, said:

They did some server maintenance a day or two ago and I have noticed an improvement but there is still some of the rubber banding issues still there, just not as frequent as before. It is still not working as well as before the patch 9.17 when the NA east lag issues started for me. I also downloaded driver booster free from IO bit and it did find some drivers to update for my sound and graphics but I don't notice any difference but still good to have the latest drivers for that stuff. If you want to check your drivers here is the link:

http://download.cnet.com/Driver-Booster/3000-18513_4-75992725.html

Make sure to decline some of the added software that it tries to install such as the browser search bars and stuff and it works great.

 

Honestly, that program and every driver program like it are absolute crap.  

dance210 #262 Posted Apr 13 2017 - 20:23

    Community Specialist

  • -Players-
  • 24318 battles
  • 4,451
  • [D4NCE] D4NCE
  • Member since:
    05-31-2012

Hi tankers!

 

If you have any additional issues or questions about the current lag issues, please see this thread. I will be closing this so that all current discussion can be in one location. Thanks!






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users