Jump to content


[1.0.2.3] scyorkie's XVM + session stats


  • Please log in to reply
195 replies to this topic

scyorkie #161 Posted May 03 2018 - 19:08

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

Edit World of Tanks\res_mods\configs\xvm\default\@xvm.xc in Notepad or similar program.

Look for line 34: "language": "auto"

Change that to: "language": "pt" or "language": "pt_BR"



Ricchi #162 Posted May 04 2018 - 01:43

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017
For some reason didn't work. I find the line, I used notepad from windows.

scyorkie #163 Posted May 04 2018 - 03:51

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

Which are the parts of XVM that are not showing up in Portuguese for you? There are some parts which I have configured to display only English, because I've only encountered English speaking users so far. I can make the relevant changes.



Ricchi #164 Posted May 04 2018 - 15:08

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017

My whole game is in english. I dont know why my game keep english even after change the line.

My game just comeback to portuguese when I remove the mod.


Edited by Ricchi, May 04 2018 - 15:09.


scyorkie #165 Posted May 04 2018 - 16:02

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011
Give me a while to international-ize my configs :)

Ricchi #166 Posted May 04 2018 - 16:42

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017
No problem dude, take your time! Your xvm is really good.

Firespray #167 Posted May 04 2018 - 21:36

    Sergeant

  • Veteran Testers
  • 16896 battles
  • 244
  • [NTR] NTR
  • Member since:
    07-09-2010
Hey Scyorkie, if I wanted to see the HP values of the enemy/friendly team, where on the XVM config would I look for to enable that?  I am using another XVM config and would prefer to use that with the addition of the health bars.

HeavyShot #168 Posted May 05 2018 - 05:50

    Sergeant

  • Players
  • 47618 battles
  • 119
  • [NUFFS] NUFFS
  • Member since:
    04-23-2011
Very nice, How would I change the OTM on enemy tanks to just tank name and HP?

scyorkie #169 Posted May 05 2018 - 06:45

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

View PostFirespray, on May 05 2018 - 04:36, said:

Hey Scyorkie, if I wanted to see the HP values of the enemy/friendly team, where on the XVM config would I look for to enable that?  I am using another XVM config and would prefer to use that with the addition of the health bars.

 

1. Go to playersPanel.xc

2. There's a whole section near the top that I've named "HP BARS"

3. Copy that section to your own config

4. Then make sure that the references to "hpBackground" etc. are included in "extraFieldsLeft" and "extraFieldsRight", under the relevant panel sections ("large", etc)

 

View PostHeavyShot, on May 05 2018 - 12:50, said:

Very nice, How would I change the OTM on enemy tanks to just tank name and HP?

 

1. To remove clan tags, go to markers.xc and

    edit line 42 from:

"format": "{{name%.10s~..}}{{clan?<font> </font>}}<font color='#a3a3a3'>{{clan}}</font>", "shadow": ${ "def.standardShadow1" }

    to:

"format": "{{name%.10s~..}}", "shadow": ${ "def.standardShadow1" }

    and edit line 48 from:

"format": "{{name}}{{clan?<font> </font>}}<font color='#a3a3a3'>{{clan}}</font>", "shadow": ${ "def.standardShadow1" }

    to:

"format": "{{name}}", "shadow": ${ "def.standardShadow1" }

 

2. To remove WN8/winrate indicators, go to markers.xc and set enabled = false at lines 52, 57, 62, 67, 73, 78, 83, and 89

 

3. To remove tank tier on pressing Alt, go to markersAliveExtended.xc and edit lines 12 and 26 from:

"levelIcon": { "enabled": true, "x": 0, "y": -78, "alpha": 100 },

    to:

"levelIcon": { "enabled": false, "x": 0, "y": -78, "alpha": 100 },



scyorkie #170 Posted May 05 2018 - 08:11

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

View PostRicchi, on May 04 2018 - 22:08, said:

My whole game is in english. I dont know why my game keep english even after change the line.

My game just comeback to portuguese when I remove the mod.

 

I went through my configs and realised that there aren't many which are set to only display English. I've updated everything except the tooltips (i.e. the stats displayed when you mouse over your tank in the garage), because that's completely customized to what I find useful and there are no applicable translations that come with XVM. You can download my modpack again for the updated configs.

 

I also tried language = pt, and language = pt_BR. There seem to be issues with the XVM translation files. For example, the "Automatically return crew" option in the garage has a translation for language = pt, but is somehow blank for language = pt_BR.

 

Screenshot:

 

Perhaps you could give examples so I can try to figure out a solution for you?



scyorkie #171 Posted May 05 2018 - 10:01

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

View PostRicchi, on May 04 2018 - 22:08, said:

My whole game is in english. I dont know why my game keep english even after change the line.

My game just comeback to portuguese when I remove the mod.

 

NVM I realise what the issue is now.

Go to World of Tanks\res_mods\1.0.1.0\ and delete the "text" folder.



scyorkie #172 Posted May 05 2018 - 17:54

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

Updated to XVM build 8350.

Damagelog now identifies premium rounds with gold text (this function was not working for a few days).



Ricchi #173 Posted May 06 2018 - 00:21

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017

View Postscyorkie, on May 05 2018 - 10:01, said:

 

NVM I realise what the issue is now.

Go to World of Tanks\res_mods\1.0.1.0\ and delete the "text" folder.

 

Thank you so much!

Ricchi #174 Posted May 06 2018 - 01:32

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017

View Postscyorkie, on May 05 2018 - 17:54, said:

Updated to XVM build 8350.

Damagelog now identifies premium rounds with gold text (this function was not working for a few days).

 

Update: The damage log dont show enemy type ammo.

scyorkie #175 Posted May 06 2018 - 07:21

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

View PostRicchi, on May 06 2018 - 08:32, said:

Update: The damage log dont show enemy type ammo.

 

It works for me though.



Ricchi #176 Posted May 06 2018 - 23:19

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017

View Postscyorkie, on May 06 2018 - 07:21, said:

 

It works for me though.

 

I found the problem, for some reason when I remove the folder "text" dont show more the type of ammo.:sceptic:

scyorkie #177 Posted May 09 2018 - 16:56

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

View PostRicchi, on May 07 2018 - 06:19, said:

I found the problem, for some reason when I remove the folder "text" dont show more the type of ammo.

 

When you remove the "text" folder, and have your XVM language set to pt_BR (whether manually or by choosing auto), the damageLog looks for this file for the shell type to display: World of Tanks\res_mods\mods\shared_resources\xvm\l10n\pt_BR.xc

 

The problem is that in that file, the relevant lines are set to display nothing:

    "armor_piercing": "",
    "high_explosive": "",
    "armor_piercing_cr": "",
    "armor_piercing_he": "",
    "hollow_charge": "",

 

There are 2 solutions.

 

The first is to edit those 5 lines in that file to the following:

    "armor_piercing": "AP",
    "high_explosive": "HE",
    "armor_piercing_cr": "APCR",
    "armor_piercing_he": "HESH",
    "hollow_charge": "HEAT",

 

The second is to edit these lines in World of Tanks\res_mods\configs\xvm\default\damageLog.xc

    "armor_piercing": "{{l10n:armor_piercing}}",
    "high_explosive": "{{l10n:high_explosive}}",
    "armor_piercing_cr": "{{l10n:armor_piercing_cr}}",
    "armor_piercing_he": "{{l10n:armor_piercing_he}}"
    "hollow_charge": "{{l10n:hollow_charge}}", 

into

    "armor_piercing": "AP",
    "high_explosive": "HE",
    "armor_piercing_cr": "APCR",
    "armor_piercing_he": "HESH"
    "hollow_charge": "HEAT", 


Ricchi #178 Posted May 10 2018 - 16:35

    Corporal

  • -Players-
  • 8671 battles
  • 27
  • [L4ST] L4ST
  • Member since:
    08-17-2017

View Postscyorkie, on May 09 2018 - 16:56, said:

 

When you remove the "text" folder, and have your XVM language set to pt_BR (whether manually or by choosing auto), the damageLog looks for this file for the shell type to display: World of Tanks\res_mods\mods\shared_resources\xvm\l10n\pt_BR.xc

 

The problem is that in that file, the relevant lines are set to display nothing:

    "armor_piercing": "",
    "high_explosive": "",
    "armor_piercing_cr": "",
    "armor_piercing_he": "",
    "hollow_charge": "",

 

There are 2 solutions.

 

The first is to edit those 5 lines in that file to the following:

    "armor_piercing": "AP",
    "high_explosive": "HE",
    "armor_piercing_cr": "APCR",
    "armor_piercing_he": "HESH",
    "hollow_charge": "HEAT",

 

The second is to edit these lines in World of Tanks\res_mods\configs\xvm\default\damageLog.xc

    "armor_piercing": "{{l10n:armor_piercing}}",
    "high_explosive": "{{l10n:high_explosive}}",
    "armor_piercing_cr": "{{l10n:armor_piercing_cr}}",
    "armor_piercing_he": "{{l10n:armor_piercing_he}}"
    "hollow_charge": "{{l10n:hollow_charge}}", 

into

    "armor_piercing": "AP",
    "high_explosive": "HE",
    "armor_piercing_cr": "APCR",
    "armor_piercing_he": "HESH"
    "hollow_charge": "HEAT", 

Ty dude. U are saving my life. xD



scyorkie #179 Posted May 14 2018 - 14:08

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011

Updated to XVM build 8362.

Most of XVM is disabled in Front Lines mode; markers still work.

I assume this is for compatibility / stability reasons.



scyorkie #180 Posted May 16 2018 - 13:25

    Major

  • Players
  • 70241 battles
  • 3,613
  • [OTTER] OTTER
  • Member since:
    10-26-2011
Patch 1.0.1.1
Updated to XVM build 8365 8368 8369.

Edited by scyorkie, May 17 2018 - 01:30.





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users