Jump to content


[1.0.0.3] YasenKrasen Colored Messages + session statistics [ENG] [11.04.2018]

YasenKrasen Session Stats Statistics Session Statistics Colored Messages 1.0.0.3

  • Please log in to reply
87 replies to this topic

Poll: [1.0.0.3] YasenKrasen Colored Messages + session statistics [ENG] [11.04.2018] (75 members have cast votes)

What Version of YasenKrasen You are using?

  1. Core (43 votes [57.33%] - View)

    Percentage of vote: 57.33%

  2. Vanilla (25 votes [33.33%] - View)

    Percentage of vote: 33.33%

  3. Mini (7 votes [9.33%] - View)

    Percentage of vote: 9.33%

What addon's for YasenKrasen You are using?

  1. Alternative In-game battle messages (Skulls) (12 votes [13.33%] - View)

    Percentage of vote: 13.33%

  2. Graphical Battle Messages (17 votes [18.89%] - View)

    Percentage of vote: 18.89%

  3. Additional backgrounds (16 votes [17.78%] - View)

    Percentage of vote: 17.78%

  4. None addon's (45 votes [50.00%] - View)

    Percentage of vote: 50.00%

Vote Guests cannot vote Hide poll

Dado_Ze #61 Posted Dec 22 2017 - 14:18

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012
Updated folder structure for 0.9.21.0.2 and added average combined damage to configs at by Tank Stats.

Dado_Ze #62 Posted Jan 11 2018 - 15:20

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012
Updated for 0.9.21.0.3

Deadpool0_0 #63 Posted Jan 12 2018 - 03:09

    Staff sergeant

  • Players
  • 23170 battles
  • 296
  • [AO] AO
  • Member since:
    02-25-2012
Only records the battles that are won,stops tracking battles after first loss..any idea why?

Dado_Ze #64 Posted Jan 12 2018 - 11:49

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

View PostDeadpool0_0, on Jan 12 2018 - 02:09, said:

Only records the battles that are won,stops tracking battles after first loss..any idea why?

 

Post your python.log.

CrymSun_Tyde #65 Posted Jan 21 2018 - 01:11

    Private

  • Players
  • 8840 battles
  • 2
  • [TRNP] TRNP
  • Member since:
    09-08-2013
I really enjoy using your mod. The only problem I have is the tank statistics numerals. What font did you use for the numbers? I use linux and need to install said font so I can see the per tank stats. I have no problem with the game session stat numbers. Thanks for the help.

Dado_Ze #66 Posted Jan 22 2018 - 11:27

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

View PostCrymSun_Tyde, on Jan 21 2018 - 00:11, said:

I really enjoy using your mod. The only problem I have is the tank statistics numerals. What font did you use for the numbers? I use linux and need to install said font so I can see the per tank stats. I have no problem with the game session stat numbers. Thanks for the help.

 

Install font Consolas or edit the config of Yasenkrasen, line byTankStats and byTankStatsPanel (if using Beta features), and change Consolas font to some other monospaced font.

CrymSun_Tyde #67 Posted Jan 26 2018 - 03:01

    Private

  • Players
  • 8840 battles
  • 2
  • [TRNP] TRNP
  • Member since:
    09-08-2013
Thanks for the help Dado_Ze.

Dado_Ze #68 Posted Feb 07 2018 - 13:57

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012
Updated for 0.9.22.0

Dado_Ze #69 Posted Feb 07 2018 - 15:01

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

If you using Beta Features and got stuck on Updating Vehicles...

 

Edit Beta Features config line "enableResearchWatchdog" to false, or redownload Beta Features inclusive config's till its fixed.

Vegalyp #70 Posted Feb 10 2018 - 20:09

    Private

  • -Players-
  • 15465 battles
  • 6
  • [CIRC] CIRC
  • Member since:
    06-18-2014

Got a quick question. I'm trying to use the Mini version of your mod like I have done for several patches now. I do the normal thing of deleting all old game version folders and then installing the new mod for the newest patch (0.9.22.0). Except, now whenever I try to start the game, I click 'Login' and then the game crashes at the 'Connecting' phase of the gear icon. It eventually recovers, but says "You were disconnected". Then, it finally allows me to click 'Login' again and will then allow me to login. However, this process takes a minute or two each time. I'm going to upload my python.log to see if anything sticks out to you.

Attached Files

  • Attached File   python.log   11.2K


Dado_Ze #71 Posted Feb 11 2018 - 00:43

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

View PostVegalyp, on Feb 10 2018 - 20:09, said:

Got a quick question. I'm trying to use the Mini version of your mod like I have done for several patches now. I do the normal thing of deleting all old game version folders and then installing the new mod for the newest patch (0.9.22.0). Except, now whenever I try to start the game, I click 'Login' and then the game crashes at the 'Connecting' phase of the gear icon. It eventually recovers, but says "You were disconnected". Then, it finally allows me to click 'Login' again and will then allow me to login. However, this process takes a minute or two each time. I'm going to upload my python.log to see if anything sticks out to you.

 

I don't see there any errors in python.log, the only thing i see something is blocking (firewall, antivirus/internet security software, router etc...) connecting to https://static.modxv...son/wn8exp.json, and that could be the same reason for not connecting to the game.

 

What you should also try, check the game files integrity from WoT Launcher - Settings - Support.



Vegalyp #72 Posted Feb 11 2018 - 02:25

    Private

  • -Players-
  • 15465 battles
  • 6
  • [CIRC] CIRC
  • Member since:
    06-18-2014

Did a file integrity check (Along with a complete uninstall/reinstall) and it borks out still. The weird thing is if I remove the mod, the game connects/logs in in ~5 seconds. I'm kind of stumped then if the log isn't showing anything unusual.

 

Edit: I turned off firewall/anti-virus/ and temporarily disabled all router security and still, it freaks out.

 

Edit 2: If I try to visit that link for the XVM expected values/etc., it connects just fine in my browser. Don't know if that helps.

 

Final Edit: I was able to fix it by going into the config.json and changing the following lines from true to false:

 

 "checkForUpdate": false,
    "updateExpectedTankValues": false,
    "updateInfoExpectedTankValues": false,

 

 I still don't get why it refused to connect properly, but I guess this fixed it sort of.

 

 

 


Edited by Vegalyp, Feb 11 2018 - 02:51.


Dado_Ze #73 Posted Feb 11 2018 - 10:08

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

Very unusual behavior, anyway there is no changes made from 0.9.21.0.1 to the mod, the updates later are only folder structure update for Mini version.

 

"checkForUpdate" line in config is checking is there a new updated mod, and has nothing to do with connecting to expected tank values host, but it makes connection to pastebin.

"updateExpectedTankValues" is the only line you need to set false, to disable auto update of expected tank values.

"updateInfoExpectedTankValues" is just in game info about updating expected tank values.

 

What could I suspect right now is the number of connections made while login in to game, also you could check ping to xvm expected values host.

 

If nothing help's you can still update manually expected tank values before starting the game, while keeping "updateExpectedTankValues" false.

Its also possible to make a batch file that updates expected tank values everytime before you start the game.



Vegalyp #74 Posted Feb 12 2018 - 02:09

    Private

  • -Players-
  • 15465 battles
  • 6
  • [CIRC] CIRC
  • Member since:
    06-18-2014
Yeah, I figured nothing really changed in the jump from 9.21 to 9.22. And like I said, I've used your mod for a long time with absolutely no problems until now. And I couldn't get it to stop crashing unless all three of those were set to false, which is weird. Whenever I pick xvm's host, I get ~30 ms ping.

Dado_Ze #75 Posted Feb 12 2018 - 11:37

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012
Check also https://pastebin.com/raw/qLxFKQUV its the host address of update check.

dasman66 #76 Posted Feb 14 2018 - 05:31

    Corporal

  • Players
  • 25795 battles
  • 12
  • Member since:
    06-05-2012

A​vgCombined - what is it and how does it differ from AvgD?

 

I searched both this and the EU forums and can't find an explanation... FWIW, installing via Aslain, so I may be missing a help file or FAQ somewhere along the lines.

 

Also... While I don't know what it is yet, I will say that it makes the bytank screen harder to read.  Not sure if this is a font size thing or what, but I find it much harder to read the new versions since AvgC was added.

 

dave



Dado_Ze #77 Posted Feb 14 2018 - 12:12

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012

AvgC is average combined damage, summed dealt, assisted by spot, assisted by track and stunned damage.

Next update of the mod I will probably remove AvgC from config.



Dado_Ze #78 Posted Feb 14 2018 - 13:49

    Corporal

  • Players
  • 41 battles
  • 64
  • Member since:
    09-30-2012
Updated for 0.9.22.0.1 and restored old style of by Tank stats.

dasman66 #79 Posted Feb 14 2018 - 15:42

    Corporal

  • Players
  • 25795 battles
  • 12
  • Member since:
    06-05-2012

Thanks for the explanation on AvgC -- makes sense and relatively important.

 

Keep up the great work... love this mod



Styo #80 Posted Mar 03 2018 - 14:48

    First lieutenant

  • Beta Testers
  • 17738 battles
  • 958
  • [-NK-] -NK-
  • Member since:
    08-11-2010
Any plans to move to the WGMods site?




5 user(s) are reading this topic

0 members, 5 guests, 0 anonymous users