Jump to content


WG, please stop showing me the website in Spanish


  • Please log in to reply
29 replies to this topic

Eugen_ #1 Posted Jun 03 2017 - 16:31

    Sergeant

  • -Players-
  • 16302 battles
  • 206
  • [OSSC] OSSC
  • Member since:
    03-10-2015

WG, please stop showing me your website in Spanish. It happens very often. I just go to worldoftanks.com and see it in Spanish.

 

home.jpg

forum.jpg

But I do not speak Spanish. I speak English, Russian and German a little. I live in the USA and as far as I understand English is the official language here

The menu does not work. I switch to English but the website is in Spanish again. After some time it fixes but it is very annoying because I have to wait.

 

menu.jpg

 

 


Edited by Eugen_, Jun 03 2017 - 16:32.


Uli_Roth #2 Posted Jun 03 2017 - 16:41

    First lieutenant

  • Players
  • 15450 battles
  • 771
  • Member since:
    09-29-2012
Rumor is WG moved it's HQ to the Tower of Babel.

Mudman24 #3 Posted Jun 03 2017 - 16:43

    Major

  • Players
  • 36283 battles
  • 11,986
  • Member since:
    04-06-2012
Press 2 for English.

Silversound #4 Posted Jun 03 2017 - 17:14

    Major

  • Players
  • 35640 battles
  • 3,082
  • [GUNS] GUNS
  • Member since:
    08-22-2011

Press crtl+F5 to request the page again.

It should sniff your region and default back to English.

 

Happened to me last night.

They are probably trying to fix break something.



nekojima #5 Posted Jun 03 2017 - 17:14

    Captain

  • Players
  • 37215 battles
  • 1,283
  • [REL-A] REL-A
  • Member since:
    09-05-2012

I had the front page in Portuguese so often, I renamed my tourney with a Portuguese name. :teethhappy:

 

This gave a double take to a couple of team members last week. When they checked the standings, thought their page was partially in Portuguese too.

 



Silversound #6 Posted Jun 03 2017 - 17:31

    Major

  • Players
  • 35640 battles
  • 3,082
  • [GUNS] GUNS
  • Member since:
    08-22-2011

I'm so frustrated with WG right now.

 

I just created a decent post about TankRewards and then upon posting it was gone.

 

I'm not new to this site...

Pretty sure WG is desperately trying to fix the many issues they are injecting into this Healthcare.gov.

 

Sometimes I wonder if they do their testing on the live servers.



Anderwar #7 Posted Jun 03 2017 - 17:36

    Staff sergeant

  • Players
  • 41925 battles
  • 396
  • [BRVE] BRVE
  • Member since:
    04-19-2013
Disculpame estoy perdido, you should start spanish courses amigo.

Eugen_ #8 Posted Jun 03 2017 - 17:46

    Sergeant

  • -Players-
  • 16302 battles
  • 206
  • [OSSC] OSSC
  • Member since:
    03-10-2015

View PostAnderwar, on Jun 03 2017 - 11:36, said:

Disculpame estoy perdido, you should start spanish courses amigo.

 

It is difficult for me. I better understand technical subjects :) My paternal side is German but I still do not speak German well.

Ironmike11B #9 Posted Jun 03 2017 - 17:50

    Captain

  • Players
  • 28094 battles
  • 1,667
  • [BOND] BOND
  • Member since:
    01-11-2013
Yeah that is one of the more annoying things about the site. Happens to me almost everyday.

Nunya_000 #10 Posted Jun 03 2017 - 17:57

    Major

  • Players
  • 20726 battles
  • 10,219
  • [PACNW] PACNW
  • Member since:
    09-20-2013

View PostEugen_, on Jun 03 2017 - 07:31, said:

WG, please stop showing me your website in Spanish. It happens very often. I just go to worldoftanks.com and see it in Spanish.

 

home.jpg

forum.jpg

But I do not speak Spanish. I speak English, Russian and German a little. I live in the USA and as far as I understand English is the official language here

The menu does not work. I switch to English but the website is in Spanish again. After some time it fixes but it is very annoying because I have to wait.

 

menu.jpg

 

 

 

Using Chrome?

riff_ #11 Posted Jun 03 2017 - 18:04

    Major

  • Players
  • 25534 battles
  • 8,427
  • Member since:
    08-02-2013

View PostEugen_, on Jun 03 2017 - 10:31, said:

WG, please stop showing me your website in Spanish. It happens very often. I just go to worldoftanks.com and see it in Spanish.

 

home.jpg

forum.jpg

But I do not speak Spanish. I speak English, Russian and German a little. I live in the USA and as far as I understand English is the official language here

The menu does not work. I switch to English but the website is in Spanish again. After some time it fixes but it is very annoying because I have to wait.

 

menu.jpg

 

 

 

"As far as I understand...."


I am sorry for this but, I can not help myself.

No, OP, you do not understand.:hiding:



El_Monstro_De_Galleta #12 Posted Jun 03 2017 - 18:26

    Sergeant

  • Players
  • 36732 battles
  • 173
  • Member since:
    12-18-2011
Oh wow I just figured this was happening to me because my name is in Spanish...even though I don't speak a lick of it.  Nice to know I guess. 

Mudman24 #13 Posted Jun 03 2017 - 18:42

    Major

  • Players
  • 36283 battles
  • 11,986
  • Member since:
    04-06-2012
Seriously, how do I changed the forum to Spanish?

LeaveIT2Beaver #14 Posted Jun 03 2017 - 18:43

    Major

  • -Players-
  • 28323 battles
  • 7,254
  • [BRIG] BRIG
  • Member since:
    07-04-2014
no mas pantalones :unsure:

Andreas007 #15 Posted Jun 03 2017 - 19:01

    Captain

  • Players
  • 38506 battles
  • 1,372
  • Member since:
    01-11-2013
Happens to me as well in Firefox.

Eugen_ #16 Posted Jun 03 2017 - 19:12

    Sergeant

  • -Players-
  • 16302 battles
  • 206
  • [OSSC] OSSC
  • Member since:
    03-10-2015

View Postriff_, on Jun 03 2017 - 12:04, said:

 

"As far as I understand...."


I am sorry for this but, I can not help myself.

No, OP, you do not understand.:hiding:

 

"Many languages are used, or historically have been used in the United States. The most commonly used language is English (specifically American English), which is the de facto national language of the United States and the primary language used for legislation, regulations, executive orders, treaties, federal court rulings, and all other official pronouncements."

ryuuto #17 Posted Jun 03 2017 - 19:15

    Sergeant

  • Players
  • 23036 battles
  • 204
  • [OARAI] OARAI
  • Member since:
    09-18-2013
They will never fix this issue. I've sent in tickets and they just say it's my browsers fault. They tell me I have to disable all my browsers plug in's and add-on's of which I have hardly any and clear my cache.... Whatever, you know when they give stupid replies like that they aren't even going to look into the issue.  Tried switching language back to English and it goes back to Spanish, though I can switch to Portuguese and it stays there. It usually happens every time I log in to the site. I'm beginning to think it's WG's way of saying "screw you America"!

Eugen_ #18 Posted Jun 03 2017 - 19:28

    Sergeant

  • -Players-
  • 16302 battles
  • 206
  • [OSSC] OSSC
  • Member since:
    03-10-2015
They scoff. It is in Spanish again and nothing helps to switch it back to English. F5, CTRL+F5, the language menu do not help.

BLADZ11 #19 Posted Jun 03 2017 - 19:31

    Corporal

  • Players
  • 52499 battles
  • 63
  • [CD_QC] CD_QC
  • Member since:
    10-07-2013
it took me 5 mins to get it bsck to english , always came back to spanish

Jester1981 #20 Posted Jun 03 2017 - 19:32

    First lieutenant

  • Players
  • 33285 battles
  • 814
  • [T-D] T-D
  • Member since:
    11-15-2012
WG isn't just content with screwing up their game anymore. Now they gotta pooch their website as well. 




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users