Jump to content


WoT Launcher downloading EXTREMELY slow/not at all


  • Please log in to reply
25 replies to this topic

NOT_SOBER #21 Posted Jul 14 2017 - 02:04

    Corporal

  • Players
  • 25418 battles
  • 10
  • Member since:
    05-25-2011
Update: Was able to patch the game via torgard and I can connect to the game servers and play without having to use torgard.  

ZombieBlaster #22 Posted Jul 14 2017 - 14:23

    Corporal

  • Players
  • 24530 battles
  • 31
  • Member since:
    06-23-2012
See my post today under website down. Same issues

Bo_Dacious #23 Posted Jul 15 2017 - 18:11

    Corporal

  • Players
  • 12342 battles
  • 37
  • [UV] UV
  • Member since:
    12-12-2011

I am having Lag issues on East server. WG needs to fix all these problems ASAP or they will lose players

 



dexatrin82 #24 Posted Jul 15 2017 - 19:02

    Staff sergeant

  • Players
  • 17750 battles
  • 316
  • [AR-PA] AR-PA
  • Member since:
    10-02-2011
Move this to Here

Saoirse #25 Posted Jul 27 2017 - 04:04

    Private

  • Players
  • 10452 battles
  • 1
  • Member since:
    02-16-2011
Not entirely sure how related this is, but I've been trying to download World of Warplanes, when the new launcher kicks in.  After that, I can't get onto the internet at all, even after I shut down the launcher.  I either have to restart my computer or, worse, have to reinstall drivers.  This is messed up.  And this is not something I should have to deal with.  Seriously, I was without Internet for two days before I figured out I needed to remove my wifi card drivers and reinstall them.

memame5547 #26 Posted Jul 31 2017 - 07:44

    Private

  • -Players-
  • 1568 battles
  • 1
  • Member since:
    12-09-2014

my game launcher does not even start the game it acts like it does and closes but nothing happens

please help

i have reinstalled the game twice but nothing has changed

 

thanks 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users