Jump to content


Disabling the launch of World of Tanks on pre-release versions of Windows 10?


  • Please log in to reply
41 replies to this topic

Mixai1l #21 Posted Jul 28 2017 - 15:00

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017

Published on WGMods.net: https://wgmods.net/W...review-fix-245/ (with WoWS support)

 

Reported in Microsoft: https://developercom...ves-incorr.html



Catch21 #22 Posted Jul 28 2017 - 17:12

    Sergeant

  • Players
  • 30393 battles
  • 155
  • [DOG5] DOG5
  • Member since:
    05-19-2013

View PostMixai1l, on Jul 27 2017 - 09:57, said:

JFYI, the error is related to the incorrect calculation of the square root in 16xxx versions of ucrtbase.dll

 

reconstructed code from Worldoftanks.exe

Spoiler

 

WoT will be starting again after the fix from Microsoft.

 

P.S. Why do I do what a community manager should do?

@Admins/WG- Please give this man a tank of his choice (Type 59?).

@Mixai1l- God bless you tovarich, spasiba!



black_colt #23 Posted Jul 28 2017 - 17:38

    Major

  • -Players-
  • 3370 battles
  • 2,147
  • Member since:
    01-11-2015

View PostCatch21, on Jul 24 2017 - 14:31, said:

Yes, I'm aware rollback is a (final) option. Please don't kill the messenger, I'm just reporting that WG has disabled even trying to launch WoT on Insider Preview versions of Win 10 without letting us know. Previously WG has worked with players and MS- along with the graphics card manufacturers- on helping get WoT to work with beta builds of Win 10. If nobody does this type of testing, everyone will eventually have problems.

 

My real issue is not informing us they were going to do this- if it's the case in my OP- when as advance testers of Win 10, we're spending our good time trying to make sure it eventually all works for others. And a lot of time wasted, including in WG's own support area, when possibly even they're not aware this is now the case.

 

Then do not use the word - controversial. There is nothing controversial about the decision not to allow - that is Wargaming right.

 

What they did is make a poor decision about not informing individuals.

 

So you are wasting time that could be better spent trying to fix the Chat services for individuals using supported systems to get Wargaming to fix the game on an unsupported system - mighty unselfish of you.  

 

Please accept my thanks for sending Support on wild-goose chases at the expense of having legitimate issues addressed for me and others.

 

 


Edited by black_colt, Jul 28 2017 - 17:56.


Baseline #24 Posted Jul 28 2017 - 18:56

    Private

  • Beta Testers
  • 6524 battles
  • 6
  • Member since:
    09-14-2010

I'm not certain if this changes your perspective any at all however what perhaps is not understood here is that Microsoft will be releasing a Fall Creators update to Windows 10 in just a matter of perhaps weeks. To date those of us in the Windows Insider program have encountered severe issue with War Gaming products in evaluation builds since 16199 and most importantly we have been reporting the issues for well over a month and nothing is getting fixed and what's worse no one is even acknowledging the problems.

 

The way the error dialogue which appears when launching WoT it would most likely seem to the average player to be a WG problem with the game. There are probably more than a few players who are in either the fast ring or more likely the slow ring of the Insider program that might not even realize the issue was coming from the new evaluation builds of Win 10. In WoWs the game launches just fine once in game there is no ship in the harbor or if you can launch into battle the camera locks and can't be moved, you can see your ship sail away as well as friendly ships sail by but nothing else can you see.

 

If MS or WG fail to sort this out between them and WG should care because if it's not addressed when the Fall Creators update comes out there are going to be some pretty pissed off tank drivers and ship captains.



Catch21 #25 Posted Jul 28 2017 - 19:02

    Sergeant

  • Players
  • 30393 battles
  • 155
  • [DOG5] DOG5
  • Member since:
    05-19-2013

View Postblack_colt, on Jul 28 2017 - 16:38, said:

 

Then do not use the word - controversial. There is nothing controversial about the decision not to allow - that is Wargaming right.

 

What they did is make a poor decision about not informing individuals.

 

So you are wasting time that could be better spent trying to fix the Chat services for individuals using supported systems to get Wargaming to fix the game on an unsupported system - mighty unselfish of you.  

 

Please accept my thanks for sending Support on wild-goose chases at the expense of having legitimate issues addressed for me and others.

Believe me, I'm used to WoT not working on Insider Preview versions of Win 10. If nobody tested it, nobody- including you- would be able to play it. What was unusual here was it just not even getting past the launch stage. And that's because they put code in to specifically not launch on a non-RTM version.

 

If you want to whinge about WG personnel being sent on wild goose chases, then consider it a WG self-inflicted wound, since nobody would have bothered them if they'd informed us what they'd done.

 

As to using the word 'controversial' that was the quote not me, so again don't kill the messenger- My OP- maybe re-read it- was an innocent look around to see if anyone else was having the same problem to try to limit WG staff resource on this.

 

Other than that, I really feel for you with your chat problems (do you get ignored often?)- polite communication doesn't seem to be your strong suit. Thanks? No problem, you're welcome.



tedgram #26 Posted Jul 28 2017 - 21:34

    Private

  • Beta Testers
  • 25689 battles
  • 5
  • [A_F_1] A_F_1
  • Member since:
    10-27-2010
Fix did not work for me. Only got to the start screen before message.

LeaveIT2Beaver #27 Posted Jul 28 2017 - 21:44

    Major

  • -Players-
  • 28323 battles
  • 7,262
  • [BRIG] BRIG
  • Member since:
    07-04-2014

View PostMixai1l, on Jul 24 2017 - 13:04, said:

I'm that guy from RU forum :)

 

Confirming this in two ways:
1. This line is stored in new WoT client, you can use IDA Pro or similar tool to check this.
2. I've got confirmation from some devs in Minsk office.

 

The only known way to bring WoT in working state back is to revert Windows 10 to release 15063 build.

 

Also, you can try to use pre-micropatch WorldOfTanks.exe (not tested) http://openwg.net/do...01/0.9.19.82.7z

 



Catch21 #28 Posted Jul 28 2017 - 23:06

    Sergeant

  • Players
  • 30393 battles
  • 155
  • [DOG5] DOG5
  • Member since:
    05-19-2013

View Posttedgram, on Jul 28 2017 - 20:34, said:

Fix did not work for me. Only got to the start screen before message.

 

Worked for me. Make sure you:

 

1) Unzip 2 files in the ZIP file to your WoT directory.

2) Run the wargaming_wip_launcher.exe executable NOT WorldoTanks.exe or WoTLauncher.exe (or their shortcuts on your desktop).

 

If still not working, revert (maybe PM?) and I'll try to help further.



Mixai1l #29 Posted Jul 28 2017 - 23:12

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017

View Posttedgram, on Jul 28 2017 - 23:34, said:

Fix did not work for me. Only got to the start screen before message.

 

In certain conditions fix may not work. I'll try to fix tomorrow. 



Mixai1l #30 Posted Jul 29 2017 - 00:05

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017
Fixed version

Attached Files

  • Attached File   Wargaming_WindowsInsiderProgram_Fix_1.4.zip   45.89K


JoeyDee86 #31 Posted Jul 29 2017 - 06:37

    Private

  • Players
  • 18382 battles
  • 2
  • [DR0ID] DR0ID
  • Member since:
    06-02-2012
Worked great for me. Anyone having problems with World of Warships too? No error message, but when in port, my ships are invisible.

Mixai1l #32 Posted Jul 29 2017 - 08:47

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017

View PostJoeyDee86, on Jul 29 2017 - 08:37, said:

Worked great for me. Anyone having problems with World of Warships too? No error message, but when in port, my ships are invisible.

 

You can also try this fix with WoWS.



Mixai1l #33 Posted Jul 31 2017 - 03:06

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017
Updated version. Hopefully fixed all the problems.

Attached Files

  • Attached File   Wargaming_WindowsInsiderProgram_Fix_1.6.zip   46.66K


Morpheus_XC #34 Posted Jul 31 2017 - 03:17

    Private

  • -Players-
  • 41 battles
  • 2
  • Member since:
    08-11-2014

View PostMixai1l, on Jul 31 2017 - 03:06, said:

Updated version. Hopefully fixed all the problems.

 

Still have the error and cant play....

lucyang1 #35 Posted Jul 31 2017 - 06:01

    Private

  • -Players-
  • 0 battles
  • 1
  • Member since:
    07-31-2017

View PostMixai1l, on Jul 27 2017 - 14:32, said:

Good news, everyone. I've made a fix!

 

Unpack to WoT folder and run Wargaming_WIP_Launcher.exe

 



Morpheus_XC #36 Posted Jul 31 2017 - 15:15

    Private

  • -Players-
  • 41 battles
  • 2
  • Member since:
    08-11-2014

View Postlucyang1, on Jul 31 2017 - 06:01, said:

 

 

I have but it still gives me the urct error....it worked for WoWs but not WoT

Catch21 #37 Posted Aug 01 2017 - 23:02

    Sergeant

  • Players
  • 30393 battles
  • 155
  • [DOG5] DOG5
  • Member since:
    05-19-2013

Check your WoT game folder/directory, make sure you have wargaming_wip_lib.dll and wargaming_wip_launcher.exe in it, then you know you unpacked the ZIP file in the correct directory.

 

Then you need to run wargaming_wip_launcher.exe NOT the shortcut that came with the game. Or create a new shortcut to use wargaming_wip_launcher.exe.



Mixai1l #38 Posted Aug 02 2017 - 12:20

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017

Microsoft is investigating

https://developercommunity.visualstudio.com/comments/88212/view.html

 


Edited by Mixai1l, Aug 02 2017 - 12:20.


Mixai1l #39 Posted Aug 02 2017 - 23:45

    Corporal

  • -Players-
  • 6 battles
  • 13
  • Member since:
    07-24-2017

Please check Insider Fast Ring 16257

Block Quote

We fixed an issue resulting in certain games such as Wargaming’s World of Tanks, World of Warships, and World of Warplanes appearing to hang/freeze shortly after launch when played on x86 PCs in recent flights.

 

 



Kratos_sv #40 Posted Aug 07 2017 - 18:42

    Private

  • -Players-
  • 13690 battles
  • 1
  • Member since:
    03-24-2016

View PostMixai1l, on Jul 27 2017 - 14:32, said:

Good news, everyone. I've made a fix!

 

Unpack to WoT folder and run Wargaming_WIP_Launcher.exe

 

Yes, this fix the problem but is safe?

 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users