Jump to content


Hardware Upgrade Help - GPU vs. 1440p Monitor


  • Please log in to reply
5 replies to this topic

Feargrim27 #1 Posted Feb 14 2020 - 19:09

    First lieutenant

  • -Players-
  • 16932 battles
  • 518
  • [PIXL-] PIXL-
  • Member since:
    04-18-2014

Gents,

 

Need expert advice. I've read so many articles all it did was confuse me.

 

I installed Battlefront 2 on my PC for the first time and with it game dropped frames / major FPS sudden drops. I played with the settings as they were all default ultra (which I found strange), and on high everything is smooth except when I enter a room with 500 people spamming grenades. 

 

After doing some research, my 4k monitor seems to be the issue, 4k gaming isn't viable unless you have significant hardware. Ok, first time my pc has ever been tested like this. 

 

Long story short, my issue is do I buy a better GPU (2080 is the one i'm eyeing) or downgrade my monitor to a 1440p. 

 

Assume money isn't an object. My issue is I've fallen in love with 4k, WoT looks amazing and I don't have an issue playing WoT on ultra in 4k but apparently in faster-paced games like Battlefront 2 I'm told you need higher refresh rates and my 4k monitor is only 60 vs. a 1440p monitor can be 144Hz. 

 

Current Specs:

 

i7-7700k - 4.2GHZ

GTX 1070 8GB

16GB RAM

 

Any advice would be appreciated.



SKurj #2 Posted Feb 14 2020 - 19:18

    Captain

  • Beta Testers
  • 14881 battles
  • 1,602
  • Member since:
    09-05-2010

that's a lot of money for gpu...   'try' a 1440 monitor...  buy it somewhere with easy return policy and see what you think.  Unless you know soemone with one you can borrow.

 

I'm happy at 1080p personally but i know what its like...   once you have tasted 4k.. you may not want to go back..

 

 



_Tsavo_ #3 Posted Feb 14 2020 - 19:48

    Major

  • Beta Testers
  • 47802 battles
  • 20,619
  • [RELIC] RELIC
  • Member since:
    02-16-2011

I'm currently running an RTX 2080 Ti on a Ryzen 7/x570 platform and using a Dell S2417DG panel.  It's a 2k panel with 144hz factory and 165 as an option.  While the 2080 Ti is a bit much, you can get basically it at 2/3 or less the price with an RTX 2080 Super variant.  These 2 cards will also tackle 4k pretty well, maybe not consistent 144 at 4k, but north of 60 for sure. 

 

My advice would be to weigh what you want more, a smoother and steadier gameplay experience or a better picture quality at the expense of consistent framerates?  For smoother and steadier gameplay, I'd go for a 2k panel and save some ducats.  The 1070 will handle 2k today, though as more titles come out you'll probably be finding some settings being turned to medium to keep 60+.  For proper  future proofing, an RTX 2080/Super/Ti. 

 

I can say my experience with my 2080 has been flawless.  It replaced a non-Ti GTX 1080 and the difference in smoothness on my panel was noticeable, I went from 70 to 144 fps on my panel to just sitting at 144 or 165 all the time.  Same for literally any other game I play.  Just sits there at 144.



bad_73 #4 Posted Feb 14 2020 - 19:49

    First lieutenant

  • -Players-
  • 1574 battles
  • 671
  • Member since:
    03-16-2019

View PostFeargrim27, on Feb 14 2020 - 19:09, said:

Gents,

 

Need expert advice. I've read so many articles all it did was confuse me.

 

I installed Battlefront 2 on my PC for the first time and with it game dropped frames / major FPS sudden drops. I played with the settings as they were all default ultra (which I found strange), and on high everything is smooth except when I enter a room with 500 people spamming grenades. 

 

After doing some research, my 4k monitor seems to be the issue, 4k gaming isn't viable unless you have significant hardware. Ok, first time my pc has ever been tested like this. 

 

Long story short, my issue is do I buy a better GPU (2080 is the one i'm eyeing) or downgrade my monitor to a 1440p. 

 

Assume money isn't an object. My issue is I've fallen in love with 4k, WoT looks amazing and I don't have an issue playing WoT on ultra in 4k but apparently in faster-paced games like Battlefront 2 I'm told you need higher refresh rates and my 4k monitor is only 60 vs. a 1440p monitor can be 144Hz. 

 

Current Specs:

 

i7-7700k - 4.2GHZ

GTX 1070 8GB

16GB RAM

 

Any advice would be appreciated.

I'm thinking the driver developers are sloughing off as my game used to run consistent in the mid 100 fps and since getting new drivers that they put a bunch of fluf with the driver and now I get frame drops into the 30's.Driver developers have all gone to adding so much extra content that isnt fully tested(just like wg) and we get more frustration.Peeps need to start telling the gpu companys to stop overstepping their purpose and just concentrate on good clean basic installs.Its so hard to get good help nowadays...lol



low_bidder #5 Posted Feb 14 2020 - 20:35

    Staff sergeant

  • -Players-
  • 26101 battles
  • 429
  • Member since:
    06-23-2015

Hi,

 

If you logon to the forum then you should be able to see my PC configuration. I have been contemplating getting a 4K monitor that will run at least 144HZ. However, I am quite pleased with my 2K monitor that normally runs at 144Hz with settings on Ultra.  I could run 165Hz but I don't see the need to do so at this time. At 144hz I see frame rates up to 300+ depending on view and terrain. Typically FPS is 200+.  I have BF 5 and BF 2 and don't have any issues at 2K with top settings.

 

If you are going to run 4K then get a better graphics card. As mentioned above, the NVIDIA RTX 2080 Super TI is not too big of a hit in the pocket book.  I am running the NVIDIA RTX 2080TI FE and it's pricey but performs extremely well in every game that I play. 

 

Did you try running your 4K monitor at 2K?



Feargrim27 #6 Posted Feb 14 2020 - 21:55

    First lieutenant

  • -Players-
  • 16932 battles
  • 518
  • [PIXL-] PIXL-
  • Member since:
    04-18-2014

Thanks for the inputs fellas.

 

@Low_bidder, yes it seems to "fix" the issue slightly, I still get dropped frames specially in the menu / loading screen. I highly doubt it's my rig though, sounds more like poor development to me.






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users