Jump to content


Solution to frequent WOT client crashes


  • Please log in to reply
138 replies to this topic

X32Wright #1 Posted Dec 03 2011 - 01:48

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
Have you had frequent and unpredictable WOT client crashes?  If you have a sound card and nVidia card (maybe ATI too) then follow the instructions below to see if it solves your problem:

Go to Control Panel and then Device Manager and locate the Display Adapter and look if you have an entry for 'High Definition Audio Controller'
 
Spoiler

Select your video card and Right Click for PROPERTIES. Look for the 'Location' entry and note the BUS and FUNCTION entries:
 
Spoiler

Do the same for the 'High Definition Audio Controller'
 
Spoiler

IF the BUS used is identical (between the video card and the HD Audio Controller) BUT the FUNCTION is different (PCI BUS 4, Function 0 and PCI BUS 4 Function 1):
 
Spoiler

'DISABLE' the 'High Definition Audio Controller'
 
Spoiler

Your WOT client would be much more stable.  It might still crash but not as often.  The problem stems from sharing the same bus (IRQ in fact) hence they interrupt each other.  The reason is most video cards today do have their own audio device built-in for HDMI output.

UPDATE: For newer video cards specially nVidia the location of the HD Audio Controller has changed.
It is no longer under the 'Sound,Video and Game Controllers section' (although sometimes it is still listed there, you cannot disable it there anymore).  

 
Spoiler

You must now go to the System Devices section to DISABLE it.
 
Spoiler

UPDATE II:  I would also check the python log.  If your python log contains a lot of missing file error, inability to read .pyc files and countless CTD (Crash to Desktop) during the game as well and have PATCH Launcher errors like "Critical Errors' , then you might have a Hard Drive problem.  You might not notice this with other programs but with WOT you will.  Sadly the solution for this is a brand new hard drive.  This I know from experience as well.


Please comment here and give tips and observation if this helped you.

Edit: This has also been tested by people with ATI video card and the same fix works. You just might have a different designation for your 'HD audio controller'.

You can also try to DISABLE, "Data Execution Prevention':
 
Spoiler



https://support.worl...-no-error-given

 

If you also have ONBOARD video and added a video card please DISABLE the ONBOARD VGA in the BIOS to prevent any IRQ conflicts or video driver conflicts.


Edited by X32Wright, Jun 29 2014 - 01:31.


Jay4hand #2 Posted Dec 03 2011 - 08:09

    Captain

  • Players
  • 10187 battles
  • 1,165
  • [_WM_] _WM_
  • Member since:
    08-17-2011
Awesome detective work!  I will let you know if it works!

Noobinit #3 Posted Dec 03 2011 - 21:10

    Corporal

  • Players
  • 2151 battles
  • 53
  • Member since:
    11-24-2011
This won't **** anything up, will it?

X32Wright #4 Posted Dec 03 2011 - 22:30

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
I shouldn't, the key to what to look for is up there.  The worse it could happen is you have no audio BUT then again why would you have two audio devices in the same system running at the same time?

Most of the problem stems from that some VIDEO card drivers also running an 'audio device' (via the HDMI output) even if you already have an onboard soundcard or a stand alone soundcard.

Noobinit #5 Posted Dec 04 2011 - 00:21

    Corporal

  • Players
  • 2151 battles
  • 53
  • Member since:
    11-24-2011

View PostX32Wright, on Dec 03 2011 - 22:30, said:

I shouldn't, the key to what to look for is up there.  The worse it could happen is you have no audio BUT then again why would you have two audio devices in the same system running at the same time?

Most of the problem stems from that some VIDEO card drivers also running an 'audio device' (via the HDMI output) even if you already have an onboard soundcard or a stand alone soundcard.

Oh its just because, you know, disabling something that, from the sound of it, is ON the video card and is part of it doesn't sound very safe y'know?

X32Wright #6 Posted Dec 04 2011 - 07:56

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
I understand your concern but this is a 'software' disable not a hardware situation.  This doesnt even affect the HAL (hardware abstraction layer) so as i said above the worse that you happen is you have no sound via HDMI.

Noobinit #7 Posted Dec 04 2011 - 15:25

    Corporal

  • Players
  • 2151 battles
  • 53
  • Member since:
    11-24-2011
Well i disabled it and my computer didnt blow up, so thats a plus.
   I'll have to see if it crashes anymore.


I'm using an ATI Radeon hd 4800 series btw.
Huh, i wonder if THIS is why my games always stutter when a sound comes in? eh, probably not.

X32Wright #8 Posted Dec 04 2011 - 21:21

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
That is probably why it stutters and ultimately crashes because of this 'shared bus but different function' issue.

stevefe #9 Posted Dec 04 2011 - 22:04

    Corporal

  • Players
  • 34975 battles
  • 65
  • [JACKL] JACKL
  • Member since:
    04-23-2011
What if your normal audio card and the hdmi audio controller us the same bus? Would that cause problems as well?

X32Wright #10 Posted Dec 05 2011 - 02:37

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
I doubt that a soundcard (internal peripheral card) would share one with a Video card on the same bus because by nature the system would designate them  on separate bus BUT an audio controller on the video card for HDMI output would certainly share the same bus as the video card.

It might happen though if you are using ONBOARD video card and ONBOARD soundcard (meaning chipset sound and video).

It took me awhile to diagnose this problem for myself since my WOT client was crashing several times a day and in some cases it was ever few mins.  This was unacceptable since I am doing SuperTesting so I had to find out what was interfering with my video card.

However in the remote case that your soundcard do share the same bus as your HDMI audio controller, then just disable one preferably the HDMI video card audio controller.

Noobinit #11 Posted Dec 05 2011 - 05:07

    Corporal

  • Players
  • 2151 battles
  • 53
  • Member since:
    11-24-2011
Hey thanks for that, seems to have work for me so far.

X32Wright #12 Posted Dec 05 2011 - 06:06

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
That's great news! :) I know it fixed mine :)

champpdthomas #13 Posted Dec 08 2011 - 00:05

    Corporal

  • Players
  • 10830 battles
  • 94
  • [_SOV_] _SOV_
  • Member since:
    05-24-2011
Thank you so much for this info, I had no ideal what was making the game crash... I hope this will fix the issue

X32Wright #14 Posted Dec 08 2011 - 08:25

    Captain

  • VT Coordinator
  • 22202 battles
  • 1,536
  • [-WC-] -WC-
  • Member since:
    09-15-2010
If you game still crashes, I suggest re-installing your client and should be fine from there.

even a windows update could make the game crash.

way_to_go_mike #15 Posted Jan 08 2012 - 04:16

    Corporal

  • Beta Testers
  • 16233 battles
  • 46
  • Member since:
    09-01-2010
i tired your fix and for the first 3 games it was perfect then it freezes up again, i have a laptop and a second monitor. i dont know if having the monitor hoked up would change anything but i use HDMI for the connection.

my game only crashes/ freezes in battle. i am downloading an nvidia update but i am not holding out much hope. i reinstalled wot yesterday and did your fix today so i guess i will reinstall again today. it is a huge pain in the ass and i think it is not worth playing if i just keep getting dissapointed every time i think i have it fixed.

thanks for your fix i hope it worked for some of you.

ulrikov #16 Posted Jan 10 2012 - 05:41

    Sergeant

  • Beta Testers
  • 5894 battles
  • 142
  • Member since:
    12-09-2010
How do you go about things... I tried disabling it, but everytime I restart, it pops up again..and I look at the Device Manager, it's back to enabled again.

Jay4hand #17 Posted Jan 10 2012 - 05:49

    Captain

  • Players
  • 10187 battles
  • 1,165
  • [_WM_] _WM_
  • Member since:
    08-17-2011

View PostX32Wright, on Dec 03 2011 - 22:30, said:

I shouldn't, the key to what to look for is up there.  The worse it could happen is you have no audio BUT then again why would you have two audio devices in the same system running at the same time?

Most of the problem stems from that some VIDEO card drivers also running an 'audio device' (via the HDMI output) even if you already have an onboard soundcard or a stand alone soundcard.
Good solution, but I am running NVIDIA HDMI to my tv, I use the second sound device when I use a headset, this in itself causes alot of conflicts, so I have given up on using a headset :(

Gohibniu #18 Posted Jan 21 2012 - 10:09

    Major

  • Players
  • 39551 battles
  • 4,642
  • [BR4WL] BR4WL
  • Member since:
    11-17-2011

View PostX32Wright, on Dec 03 2011 - 01:48, said:

Have you had frequent and unpredictable WOT client crashes (including ST client)?  If you have a sound card and nVidia card (maybe ATI too) then follow the instructions below to see if it solves your problem:

Go to Control Panel and then Device Manager and locate the Display Adapter and look if you have an entry for 'High Definition Audio Controller'

Spoiler                     

Select your video card and Right Click for PROPERTIES. Look for the 'Location' entry and note the BUS and FUNCTION entries:

Spoiler                     

Do the same for the 'High Definition Audio Controller'

Spoiler                     

IF the BUS used is identical (between the video card and the HD Audio Controller) BUT the FUNCTION is different (PCI BUS 4, Function 0 and PCI BUS 4 Function 1):

Spoiler                     

'DISABLE' the 'High Definition Audio Controller'

Spoiler                     

Your WOT client would be much more stable.  It might still crash but not as often.  The problem stems from sharing the same bus (IRQ in fact) hence they interrupt each other.  The reason is most video cards today do have their own audio device built-in for HDMI output.

Please comment here and gives tips and observation if this helped you.

Edit: This has also been tested by people with ATI video card and the same fix works. You just might have a different designation for your 'HD audio controller'.


Ok going to try it.

Still crashes, but I think it is less.  Appears to not have any effect on getting exiled to la la land during map generation.  Defragged and the first game after...it crashed!! so defrage doesnt have anything to do with it.

UncleJester #19 Posted Feb 05 2012 - 10:35

    Private

  • Players
  • 10202 battles
  • 1
  • Member since:
    02-21-2011
X32Wright -

I just wanted to let you know this worked fantastic with my ATI Radeon 4800 card installed on my Win 7.

My FPS went from a very unstable 4-16 FPS to a much more respectable 35-45 FPS.  Additionally, all of the hesitations, stutters, and lag moments have all but disappeared completely!

Thanks again!

atsiv #20 Posted Feb 05 2012 - 14:54

    First lieutenant

  • Players
  • 12879 battles
  • 550
  • [-RAH-] -RAH-
  • Member since:
    03-21-2011
lol i have 2 high definition audio controllers.not on the same bus though.disabled the one that used the same as my gts 450 left the other one alone




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users