Jump to content


Phantom/Ghost/Disappearing Shots


This topic has been archived. This means that you cannot reply to this topic.
12 replies to this topic

BadBadger #1 Posted Jan 02 2012 - 07:36

    Corporal

  • Beta Testers
  • 0 battles
  • 21
  • Member since:
    10-30-2010
I have searched the forums on numerous occasions and have read that  people believe this to be a bug. They could well be correct. I have seen ghost shots many times, but only when playing arty. This only happens during a blind shot when I know the tank is there, usually because I saw it just prior to shooting, or the tank vanishes right as I'm pulling the trigger. The tank is invisible, I see no explosion, and get no audible feedback from sound fx or crew to let me know I actually hit the target. I have a theory that seems to explain it:

If you blind hit a tank, you should obviously see no ground explosion. However, you might expect to see or hear something that lets you know the tank is there and was hit, but you don't. I propose that this is the way the game lets you know that though you hit something, you can't know how much, nor what kind of damage was done until the tank is again spotted by someone. Obviously, if you kill the tank during a blind shot, the (dead) tank appears, and you receive audible and visual conformation of the kill. However, the instant the tank reappears (is spotted) I can always see the damage that I have done (assuming damage was done).

After countless ghost hits from my arty, I have always found this to be true. Please let me know if this makes any sense or if this is not what people are referring to.

thandiflight #2 Posted Jan 02 2012 - 07:41

    Major

  • Players
  • 0 battles
  • 2,049
  • Member since:
    07-10-2011
After 404 battles in my Object 212 and numerous in my S-51, I have noticed these "ghost shots"

The reticle is zeroed in, I see all the dots forming the oval/circle

And then, the shot just doesn't come, no tracer, no explosion, nothing.

But the occurence of these shots are quite low for me.

havocy #3 Posted Jan 02 2012 - 08:15

    Corporal

  • Players
  • 0 battles
  • 50
  • Member since:
    05-31-2011
if u fire blindly and there is no explosion and your shot traces is there that means u have had a direct shot.. this mostly happens with arty..
i found out when i fired at a tank he disappeared and had no shot expolsion.. a few sec later he was scout and had damage.. same happened again this time i found him at 6% after he was scouted after my 2nd shot

Flintwikk #4 Posted Jan 02 2012 - 08:58

    Sergeant

  • Beta Testers
  • 0 battles
  • 105
  • Member since:
    09-25-2010
Well I play Tank Destroyers I have all the top tier TD's and I have found on more occasions then I care to remember that I fire a round at a target and there is no hit registration what so ever and this is from shots you know would have hit the target (under 100 meters) ,the shot just vanishes.What makes it more promonent is when the target is beside a hill or building and there is no splash from a missed shot.

I have found that this has made it self know again since the 7.0 patch.I just wish they would fix issues like this,to add to this bug the "we hit them hard" and no damage to the target is getting real annoying in 7.0 also :(

Mankoi #5 Posted Jan 02 2012 - 09:13

    Captain

  • Players
  • 0 battles
  • 1,028
  • Member since:
    04-22-2011

View Posthavocy, on Jan 02 2012 - 08:15, said:

if u fire blindly and there is no explosion and your shot traces is there that means u have had a direct shot.. this mostly happens with arty..
i found out when i fired at a tank he disappeared and had no shot expolsion.. a few sec later he was scout and had damage.. same happened again this time i found him at 6% after he was scouted after my 2nd shot

I will agree with Havocy.

If an arty shot disappeares it means you have hit em . and hit em well.

RonZarper #6 Posted Jan 02 2012 - 09:19

    Major

  • Beta Testers
  • 0 battles
  • 9,004
  • Member since:
    07-10-2010
edit: What he said ^
Well in arty if ya don't see a splash on a non spotted target it means ya nailed him...

Thanatos69 #7 Posted Jan 02 2012 - 11:05

    Sergeant

  • Players
  • 0 battles
  • 156
  • Member since:
    03-20-2011
I think this covers a large portion of these instances but not all.  Largely, I find it hard to believe that I could put 5 203mm shells of my 212 into a T30 and only hurt him for about 15% after watching all shells disappear in the spot he was hiding.

And there is also a rare chance that a shell won't even leave your barrel and thus have zero chance of hurting anything; this I've noticed several times throughout the few thousand games I've played.

Perhaps there is a very obscure and undocumented/undisclosed 'dud' chance.

SKYeXile #8 Posted Jan 02 2012 - 11:11

    Staff sergeant

  • Players
  • 0 battles
  • 265
  • Member since:
    06-26-2011
Happens all the time on my E50, reticule full encloses the enemy tank, no registration of hit or bounce, shot goes straight through them or something. Poor netcode i guess, possibly due to the game having a lagged target reticule compared to what you see. Wargaming should call value and get some proper netcode.

BadBadger #9 Posted Jan 02 2012 - 11:51

    Corporal

  • Beta Testers
  • 0 battles
  • 21
  • Member since:
    10-30-2010
Thanks, everyone, for clarifying what I assumed to be how blind hits work. I have never read that in documentation nor forums.

Regarding tracerless, hitless, WTF non-shots, I very rarely see them since beta and early live versions. I too used to wonder if those were an undocumented/undisclosed 'dud' feature, but then why were we not hearing some variation of "Aw shit!" from the commander? It's really not a terribly bad idea, but if the frequency of duds were accurately represented, I suppose no one would want to play the German tanks. lol

UrbanUK #10 Posted Jan 02 2012 - 12:08

    Sergeant

  • Beta Testers
  • 0 battles
  • 104
  • Member since:
    07-04-2010
I've have often wondered about "ghost" shells. I've seen them in a few tanks I drive, more noticably in the E-75, IS-4 and JadgTiger as I tend to pay more attention when firing "teh big gunz" as those shots can be game changers...

I've often wondered whether it is a packet thing; the client-end knows you fired but the data packet didn't make it to the server therefore the server doesn't know you fired, hence no feedback, no background explosion, no tracer, nothing. It is kinda weird.

Just to clarify, I know with the arty if you see nothing it generally means you hit what you were aiming at but couldn't see; I'm just talking about tanks and TD's.

Deuces_Wild #11 Posted Jan 02 2012 - 17:46

    Staff sergeant

  • Players
  • 0 battles
  • 304
  • Member since:
    12-12-2011
Happens alot with my Sherman and now with the Tiger I.and at point blank range more then a few times...has a weird sound to it to I noticed

BadBadger #12 Posted Jan 02 2012 - 17:51

    Corporal

  • Beta Testers
  • 0 battles
  • 21
  • Member since:
    10-30-2010

View PostUrbanUK, on Jan 02 2012 - 12:08, said:

I've often wondered whether it is a packet thing; the client-end knows you fired but the data packet didn't make it to the server therefore the server doesn't know you fired, hence no feedback, no background explosion, no tracer, nothing. It is kinda weird.

A buddy and I were discussing your theory, and right or wrong, we agree that it is a very rational and satisfactory explanation. It would also explain why this hasn't been specifically or fully addressed by the developers. It could simply be a result of network issues that, for the most part, are beyond their control. What might be interesting would be if people reporting seeing these events were able to correlate them with spikes of high pings. Regardless, I am satisfied with that explanation and have received conformation of my original idea regarding blind, but tracered shots.

Thanks everyone. Happy New Year and Happy Hunting!

ironronin #13 Posted Apr 15 2012 - 20:51

    Private

  • Players
  • 0 battles
  • 6
  • Member since:
    09-08-2011
I have this issue, but it was most noticeable during the 1year Anniversary Event. About half my shots would vanish. I noticed that my ping would spike each time it happened, so I believe it to be lag based. Hope this helps.