Jump to content


Low FPS, Interface problem?


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

ragnarocc #-19 Posted Feb 26 2012 - 12:57

    Corporal

  • Players
  • 0 battles
  • 46
  • Member since:
    02-25-2012
Specs:
Operating System
MS Windows 7 64-bit SP1
CPU
AMD Phenom II X4
Deneb 45nm Technology
RAM
8.00 GB Dual-Channel DDR3 @ 802MHz (11-11-11-29)
Motherboard
ASUSTeK Computer INC. M4A78T-E (AM3) 38 °C
Graphics
VX2240w (1680x1050@59Hz)
ATI Radeon HD 4850 (XFX Pine Group) 45 °C
Hard Drives
733GB Seagate ST3750528AS ATA Device (SATA) 33 °C
Optical Drives
KZQBIL CTIVC5E3 SCSI CdRom Device
ATAPI DVD C  DH52C2P ATA Device
Audio
VIA High Definition Audio
Internet speed http://www.speedtest.net/result/1797622709.png

Now for the problem...
I'm getting 4-7 fps on very high settings and 6-9 fps on the lowest of the low settings. This is in game play and in the main menu/garage/barracks. My mouse will track across the screen so slow it's hard to click on buttons. However, if I join a battle and press the 'v' key to turn off the interface, my fps speeds up. I can't see what they go to, but the game goes from unplayable to tolerable, though it does put my cpu through a workout in terms of heating it up.
Any thoughts on how to fix this, other than just keep hiding the HUD?

Epine #-18 Posted Feb 26 2012 - 13:20

    Corporal

  • Players
  • 0 battles
  • 28
  • Member since:
    06-08-2011
since you're processor is 4 core, WoT is only using 1/4 of your processing power

dwaindwarf #-17 Posted Feb 26 2012 - 13:21

    Captain

  • Players
  • 0 battles
  • 1,956
  • Member since:
    06-18-2011
Have you tried any of this ?

Low FPS


Install the latest version of your video card driver:
- Nvidia: http://www.nvidia.co...aspx?lang=en-us
- AMD/ATI drivers: http://game.amd.com/...s_catalyst.aspx

Install this version of Visual C++ 2008 SP1 Redistributable Package:
(х64) http://www.microsoft...14-157CFDFFEE4E
(х86) http://www.microsoft...0D-3802B2AF5FC2

Install Visual C++ 2010 if you're running Windows Vista or Windows 7:
(х64) http://www.microsoft...BF-9350143D5867
(х86) http://www.microsoft...23-37BF0912DB84

Install .NET Framework and/or it's updates in the given order.
- .NET Framework 2.0 SP2: http://www.microsoft...1d-10e506da9d0f
- .NET Framework 3.0: http://www.microsoft...f5-25634c3bf043
- .NET Framework 3.5: http://www.microsoft...19-81da479ab0d7
- .NET Framework 4.0: http://www.microsoft...e5-b386f32c0992

dwaindwarf #-16 Posted Feb 26 2012 - 13:26

    Captain

  • Players
  • 0 battles
  • 1,956
  • Member since:
    06-18-2011
Check this out it may help... Troubleshooter

Good luck

HOTA_CHATON #-15 Posted Feb 26 2012 - 14:34

    Major

  • Players
  • 0 battles
  • 8,403
  • Member since:
    09-28-2011
He can always go to game settings and turn on color blind mode.  I am running so much better in that mode, it is not funny.  It takes a few battles to get used to the
new colors but you will and I picked up10 to 15 FPS with it.  Try it and see what you think.
But I think his problem is always going to be the video card he has, I may be wrong but it look like it's integrated and not stand alone.  Correct me if I am wrong.

Questman #-14 Posted Feb 26 2012 - 15:20

    Corporal

  • Players
  • 0 battles
  • 23
  • Member since:
    11-09-2011
try downloading a program called game boaster it removes back ground programs, and help improve fps rating

http://www.iobit.com/gamebooster.html

ZombieFlanders #-13 Posted Feb 26 2012 - 16:31

    Major

  • Beta Testers
  • 0 battles
  • 2,708
  • Member since:
    09-29-2010
try game-booster, but unless your system is really bloated with spyware/viri/loads of background stuff etc...it wont do much.  it helps to clean things up and it closes background apps that you dont need.  you have 8gig ram though, the game uses ~1.5, so you might get a few FPS but dont expect a lot.  

update your drivers. these are the latest, along with the latest   CAP   . then make sure that all of the driver settings are at default and autodetect the in-game settings.  also, if you havent done so in a while perform a HD defrag. once again the gain in FPS wont be huge, but every bit counts.  

another thing, as mentioned above the game is essentially single threaded.  what is your CPU speed? if its much under 3Ghz then you have a bottleneck issue that can only be fixed by overclocking (is turbo core on?) or a CPU upgrade.  there are some tweaks you can do to try to get the game to use more cores but none have every done anything for me.

ragnarocc #-12 Posted Feb 27 2012 - 22:20

    Corporal

  • Players
  • 0 battles
  • 46
  • Member since:
    02-25-2012
So... My cpu is overclocked to just 3010 Mhz and noticed the game using most of one core (90-100%) and about 5-15% of two other cores while running. The GPU is a stand alone PCI-E card and it's not being pushed above 40%. I have the latest drivers and I use VS2010 ultimate (VC++ and .net are up to date). I ran a performance analysis and got the following:
Process -> Pid -> Module																						Ret inst 	ITLB requests 	ITLB L1M L2H 	ITLB L1M L2M 	ITLB request rate 	ITLB L1M L2H rate 	ITLB L1M L2M rate 	
WorldOfTanks.exe																								420391   	120122			13132			166		  	25.65			 	0.33			  	0				 	
PID : 1852																								  	420391   	120122			13132			166		  	25.65			 	0.33			  	0				 	
C:\Windows\system32\ntoskrnl.exe																				149512   	40858		 	445		  	2				0.27			  	0				 	0				 	
C:\Windows\SysWOW64\ntdll.dll																			   	97214		27712		 	4199		 	16		   	0.29			  	0				 	0				 	
C:\Games\World_of_Tanks\WorldOfTanks.exe																		60210		17580		 	2191		 	48		   	0.29			  	0				 	0				 	
unknown module pid (1852)																				   	42423		11590		 	1702		 	8				0.27			  	0				 	0				 	
C:\Windows\SysWOW64\d3d9d.dll																			   	15289		4850		  	1172		 	24		   	0.32			  	0.01			  	0				 	
C:\Windows\SysWOW64\atiumdag.dll																				10438		3556		  	480		  	18		   	0.34			  	0				 	0				 	
C:\Windows\System32\wow64.dll																			   	9560	 	3494		  	878		  	6				0.37			  	0.01			  	0				 	
C:\Windows\System32\wow64cpu.dll																				6868	 	2574		  	995		  	2				0.37			  	0.01			  	0				 	
C:\Windows\winsxs\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\msvcr90.dll  	5412	 	1718		  	329		  				 	0.32			  	0.01			  					  	
C:\Windows\SysWOW64\D3DCompiler_43.dll																	  	5061	 	1480		  	46		   				 	0.29			  	0				 					  	
C:\Windows\SysWOW64\D3DX9_43.dll																				4772	 	924		   	4				2				0.19			  	0				 	0				 	
C:\Games\World_of_Tanks\fmodex.dll																		  	4753	 	850		   	3				6				0.18			  	0				 	0				 	
C:\Windows\winsxs\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\msvcp90.dll  	3142	 	1174		  	167		  				 	0.37			  	0.01			  					  	
C:\Windows\SysWOW64\kernel32.dll																				2016	 	594		   	406		  	4				0.29			  	0.02			  	0				 	
C:\Windows\system32\DRIVERS\atikmdag.sys																		1016	 	330		   	5				4				0.32			  	0				 	0				 	
C:\Windows\System32\Drivers\Ntfs.sys																			724	  	198		   	22		   	4				0.27			  	0				 	0				 	
C:\Windows\system32\drivers\fltmgr.sys																	  	364	  	154		   	32		   	2				0.42			  	0.01			  	0				 	
C:\Windows\System32\win32k.sys																			  	246	  	80				7				2				0.33			  	0				 	0				 	
C:\Windows\SysWOW64\atiumdva.dll																				216	  	40							 				 	0.19			  					  					  	
C:\Games\World_of_Tanks\vivoxsdk.dll																			130	  	44				2				2				0.34			  	0				 	0				 	
C:\Windows\SysWOW64\d3dx9_31.dll																				128	  	42				5							 	0.33			  	0				 					  	
C:\Games\World_of_Tanks\libeay32.dll																			121	  	18				1				2				0.15			  	0				 	0				 	
C:\Windows\SysWOW64\cryptsp.dll																			 	96	   	12							 				 	0.12			  					  					  	
C:\Windows\System32\drivers\dxgkrnl.sys																	 	94	   	38				3							 	0.4			   	0				 					  	
C:\Windows\SysWOW64\atiu9pag.dll																				77	   	20				20		   	2				0.26			  	0.03			  	0				 	
C:\Windows\system32\DRIVERS\MpFilter.sys																		71	   	28				2							 	0.39			  	0				 					  	
C:\Games\World_of_Tanks\fmod_event_net.dll																  	59	   	12							 				 	0.2			   					  					  	
C:\Windows\system32\drivers\fileinfo.sys																		49	   	30				2							 	0.61			  	0				 					  	
C:\Windows\SysWOW64\aticfx32.dll																				48	   	12							 				 	0.25			  					  					  	
C:\Windows\System32\drivers\dxgmms1.sys																	 	40	   	16				1							 	0.4			   	0				 					  	
C:\Windows\system32\DRIVERS\atikmpag.sys																		32	   	8			 	1							 	0.25			  	0				 					  	
C:\Windows\system32\hal.dll																				 	20	   	12							 				 	0.6			   					  					  	
C:\Windows\System32\Drivers\spsf.sys																			17	   	4			 	1				2				0.24			  	0.01			  	0				 	
C:\Windows\SysWOW64\usp10.dll																			   	16	   	2			 				 				 	0.12			  					  					  	
C:\Windows\System32\wow64win.dll																				16	   	6			 	2							 	0.38			  	0.01			  					  	
C:\Windows\system32\drivers\luafv.sys																	   	16	   				  	5							 					  	0.03			  					  	
C:\Windows\SysWOW64\AudioSes.dll																				15	   	2			 				 	2				0.13			  					  	0				 	
C:\Windows\SysWOW64\d3d9.dll																					10	   	2			 				 				 	0.2			   					  					  	
C:\Windows\System32\drivers\tcpip.sys																	   	10	   	4			 				 				 	0.4			   					  					  	
C:\Windows\SysWOW64\MMDevAPI.dll																				9						  				 				 					  					  					  	
C:\Windows\system32\drivers\afd.sys																		 	6			6			 	2							 	1				 	0.03			  					  	
C:\Games\World_of_Tanks\umbra.dll																		   	5						  				 				 					  					  					  	
C:\Windows\SysWOW64\wdmaud.drv																			  	5			6			 				 				 	1.2			   					  					  	
C:\Windows\SysWOW64\winmm.dll																			   	5			6			 				 				 	1.2			   					  					  	
C:\Windows\System32\cdd.dll																				 	5			2			 				 				 	0.4			   					  					  	
C:\Windows\System32\drivers\watchdog.sys																		5			6			 				 				 	1.2			   					  					  	
C:\Windows\system32\drivers\NETIO.SYS																	   	5						  				 				 					  					  					  	
C:\Program Files (x86)\ATI Technologies\HydraVision\HydraDMH.dll												4						  				 				 					  					  					  	
C:\Windows\SysWOW64\dinput8.dll																			 	4			2			 				 				 	0.5			   					  					  	
C:\Games\World_of_Tanks\uwApi.dll																		   	3						  				 	4								  					  	0				 	
C:\Windows\SysWOW64\mswsock.dll																			 	3						  				 				 					  					  					  	

1 process, 70.24% of shown samples

I'll see what else I can dig out of things.
And any thoughts to the cause?